Error setting up database 'ee_mysql_grant_host'


#1

Greetings, I have tried to use:

sudo ee site create gravatodesign.com --wp

With the following results.

Running pre-update checks, please wait...
Setting up NGINX configuration  [Done]
Setting up webroot              [Done]
Downloading WordPress           [Done]
Setting up database             Oops Something went wrong !!
Calling cleanup actions ...
'ee_mysql_grant_host'

I have created three or 4 sites in this fashion prior to updating and upgrading Ubuntu (14.04.4 LTS) and installing phpmyadmin with

ee stack install phpmyadmin

I think there may be a configuration problem since these updates and upgrades. Not sure where to begin because I am a noob.

Current version of EasyEngine is v3.5.3

Output of tail -n50 var/log/ee/ee.log is

2016-03-13 03:15:29,053 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2016-03-13 03:15:29,337 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'create', 'gravatodesign.com', '--wp']
2016-03-13 03:15:29,338 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f8c0d59c5c0>
2016-03-13 03:15:29,340 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f8c0d59c748>
2016-03-13 03:15:29,342 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteCreateController object at 0x7f8c0d5a9080>
2016-03-13 03:15:29,346 (INFO) ee : Initializing EasyEngine Database
2016-03-13 03:15:29,356 (DEBUG) ee : Setting apt_packages variable for Nginx
2016-03-13 03:15:31,354 (DEBUG) ee : Finding string SCRIPT_FILENAME to file /etc/nginx/fastcgi_params
2016-03-13 03:15:31,357 (DEBUG) ee : Setting apt_packages variable for PHP
2016-03-13 03:15:33,304 (DEBUG) ee : Setting apt_packages variable for MySQL
2016-03-13 03:15:33,305 (DEBUG) ee : Running command: mysqladmin ping
2016-03-13 03:15:33,343 (DEBUG) ee : Command Output: mysqld is alive
,
Command Error:
2016-03-13 03:15:33,344 (DEBUG) ee : Setting apt_packages variable for Postfix
2016-03-13 03:15:35,146 (DEBUG) ee : Setting packages variable for WP-CLI
2016-03-13 03:15:35,146 (DEBUG) ee : Running command: which wp
2016-03-13 03:15:35,162 (DEBUG) ee : Command Output: /usr/bin/wp
,
Command Error:
2016-03-13 03:15:35,164 (INFO) ee : Running pre-update checks, please wait...
2016-03-13 03:15:35,165 (DEBUG) ee : checking NGINX configuration ...
2016-03-13 03:15:35,245 (INFO) ee : Setting up NGINX configuration
2016-03-13 03:15:35,247 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2016-03-13 03:15:35,252 (DEBUG) ee : Checking generated nginx conf, please wait...
2016-03-13 03:15:35,309 (INFO) ee : [Done]
2016-03-13 03:15:35,310 (DEBUG) ee : Creating Symbolic link, Source:/etc/nginx/sites-available/gravatodesign.com, Dest:/etc/nginx/sites-enabled/gravatodesign.com
2016-03-13 03:15:35,310 (INFO) ee : Setting up webroot
2016-03-13 03:15:35,311 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/gravatodesign.com.access.log, Dest:/var/www/gravatodesign.com/logs/access.log
2016-03-13 03:15:35,311 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/gravatodesign.com.error.log, Dest:/var/www/gravatodesign.com/logs/error.log
2016-03-13 03:15:35,312 (INFO) ee : [Done]
2016-03-13 03:15:35,396 (INFO) ee : Downloading WordPress
2016-03-13 03:15:35,397 (DEBUG) ee : Changing directory to /var/www/gravatodesign.com/htdocs/
2016-03-13 03:15:35,398 (DEBUG) ee : Running command: wp --allow-root core download
2016-03-13 03:15:37,261 (DEBUG) ee : Command Output: Downloading WordPress 4.4.2 (en_US)...
Using cached file '/root/.wp-cli/cache/core/wordpress-4.4.2-en_US.tar.gz'...
Success: WordPress downloaded.
,
Command Error:
2016-03-13 03:15:37,263 (INFO) ee : [Done]
2016-03-13 03:15:37,264 (DEBUG) ee : Autofix MySQL username (ERROR 1470 (HY000)), please wait
2016-03-13 03:15:37,264 (INFO) ee : Setting up database
2016-03-13 03:15:37,264 (DEBUG) ee : Creating database gravatodesign_com
2016-03-13 03:15:37,267 (DEBUG) ee :
2016-03-13 03:15:37,268 (DEBUG) ee : 'MySQL Connectivity problem occured'
2016-03-13 03:15:37,268 (INFO) ee : Oops Something went wrong !!
2016-03-13 03:15:37,268 (INFO) ee : Calling cleanup actions ...
2016-03-13 03:21:00,682 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2016-03-13 03:21:00,983 (DEBUG) ee : ['/usr/local/bin/ee', '-v']
2016-03-13 03:21:00,983 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fd2eb4ae630>

and I am able to access MariaDB with mysql command.

The credentials stored in /etc/mysql/conf.d/my.cnf appear to be the same as the credentials I use to access phpmyadmin from my browser.

The database attempting to be created does not already exist.

I hope I have provided enough information. I have read about similar issues on this forum but have not been able to resolve my issue.

Thank you,


#2

did you ever find out a fix for this??


#3