Error: No such file or directory: '/usr/bin/wp'


#1
Downloading WP-CLI  [Errno 2] No such file or directory: '/usr/bin/wp'

I’m getting this error while using ee site create example.com --wp command and still no site created. But html website command ee site create example.com --html works fine.

I’m using the latest version: EasyEngine 3.0.4


#2

@johnarce

you can install wpcli with ee stack install --wpcli and then try to create site with --wp option. seems some problem with wpcli installation on your server.


#3

I have the same issue as the person above. See screenshot. I attempted ee stack install --wpcli and this notification happens when I attempt that as well.

I also tried this as root… same thing.

This particular server is running Ubuntu 12.04. I’ve attempted to upgrade it to 14.04, and it never works. Always fails on that as well. Any other ideas are appreciated.


#4

Hi @johnarce

Please try the latest Easyengine , You can update to latest version using following command:

ee update

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#5