Error logging into phpMyAdmin?


#1

Hi,

Just installed EE and am trying to access phpMyAdmin. I have found the root password located in /etc/mysql/conf.d/my.cnf.

When I log in I get some errors and can’t get in. Currently, I don’t have a domain setup so am using the droplets IP. Not sure if this would be causing the issue or not?

When I enter my details I get this:

When I click the back button to bring up phpmyadmin login screen again these come up:

Thanks Trent


#2

Try to use a domain name pointing to that server also create another user database user that is not root and grant all permissions to all the databases it on the command line and use it to login instead. Always remember root@localhost is not the same as root@domain to mysql.


#3

I kind of wanted to access phpMyAdmin so I could transfer my site over. So currently thats why I dont have domain setup yet.

Is the error caused from not using a domain name or is root@localhost vs root@domain - Can you elaborate on the this as well, not sure I know what you mean. I am using Digital Ocean so don’t think localhost login applies?

Thanks


#4

Log into your server via ssh and run the following commands:

mysql -u root-p
CREATE USER 'newuser'@'localhost' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON * . * TO 'newuser'@'localhost';
FLUSH PRIVILEGES;

NB Please change the newuser and password part to match your preferences You will be asked to enter your root password when you run the first command

Login via phpMyadmin using the newuser and password


#5

Hey mate,

Tried this as well as using domain name rather than server Ip and am still getting the same issue. Could it be a SSL issue as it’s using a self signed SSL?


#6

Sorry for the late reply I was AFK. I have to admit I am stumped. I haven’t encountered this before. Have you managed to resolve this?


#7

Same error since I’m trying to use EE with php7 on debian. I will go back to ubuntu quickly.


#8

@rexi88 We are looking in the issue. As a quick fix for the moment, You can install the package php5-mysqlnd that will fix this error.

Thank you for your patience.


#9

Thank you. will give it a try when I get a chance. Thank you.


#10

@rexi88 Yes, do try and let us know. Thank you.


#11