Error Installing Easyengine 3.0.2


#1

I’m using ramnode VPS for my 3 sites without any problem. Today I bought new server and install Easyengine. When I run ee stack install, this error shows

Adding repository for MySQL Adding repository for Nginx Adding repository for PHP Error occurred while executing command

Here’s my ee.log

2015-02-14 11:06:19,440 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-02-14 11:06:19,619 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0xa4403ac>
2015-02-14 11:06:19,621 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack.EEStackController object at 0xa440aec>
2015-02-14 11:06:19,622 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_services.EEStackStatusController object at 0xa440cec>
2015-02-14 11:06:19,626 (DEBUG) ee : ^[[95mSetting apt_packages variable for Nginx ,PHP ,MySQL ^[[0m
2015-02-14 11:06:19,627 (DEBUG) ee : ^[[95mSetting apt_packages variable for Nginx^[[0m
2015-02-14 11:06:22,137 (DEBUG) ee : ^[[95mSetting apt_packages variable for PHP^[[0m
2015-02-14 11:06:22,796 (DEBUG) ee : ^[[95mSetting apt_packages variable for MySQL^[[0m
2015-02-14 11:06:22,796 (DEBUG) ee : ^[[95mRunning command: mysqladmin ping^[[0m
2015-02-14 11:06:22,801 (DEBUG) ee : ^[[95m/bin/sh: 1: mysqladmin: not found^[[0m
2015-02-14 11:06:22,801 (DEBUG) ee : ^[[95mSetting apt_packages variable for Postfix^[[0m
2015-02-14 11:06:23,459 (DEBUG) ee : ^[[95mSetting packages variable for WP-CLI^[[0m
2015-02-14 11:06:23,459 (DEBUG) ee : ^[[95mRunning command: which wp^[[0m
2015-02-14 11:06:23,467 (DEBUG) ee : ^[[95m^[[0m
2015-02-14 11:06:23,467 (DEBUG) ee : ^[[95mCalling pre_pref^[[0m
2015-02-14 11:06:23,467 (DEBUG) ee : ^[[95mPre-seeding Postfix^[[0m
2015-02-14 11:06:23,467 (DEBUG) ee : ^[[95mRunning command: echo "postfix postfix/main_mailer_type string 'Internet Site'" | debconf-set-selections^[[0m
2015-02-14 11:06:23,615 (DEBUG) ee : ^[[95mRunning command: echo "postfix postfix/mailname string $(hostname -f)" | debconf-set-selections^[[0m
2015-02-14 11:06:23,744 (INFO) ee : ^[[94mAdding repository for MySQL^[[0m
2015-02-14 11:06:23,744 (DEBUG) ee : ^[[95mAdding key for deb http://repo.percona.com/apt precise main^[[0m
2015-02-14 11:06:23,744 (DEBUG) ee : ^[[95mRunning command: gpg --keyserver keyserver.ubuntu.com --recv-keys 1C4CBDCDCD2EFD2A^[[0m
2015-02-14 11:06:23,991 (DEBUG) ee : ^[[95mRunning command: gpg -a --export --armor 1C4CBDCDCD2EFD2A | apt-key add - ^[[0m
2015-02-14 11:06:24,033 (DEBUG) ee : ^[[95mPre-seeding MySQL^[[0m
2015-02-14 11:06:24,033 (DEBUG) ee : ^[[95mRunning command: echo "percona-server-server-5.6 percona-server-server/root_password password NweqrFhz" | debconf-set-select$
2015-02-14 11:06:24,424 (DEBUG) ee : ^[[95mRunning command: echo "percona-server-server-5.6 percona-server-server/root_password_again password NweqrFhz" | debconf-set-$
2015-02-14 11:06:24,562 (DEBUG) ee : ^[[95mWritting configuration into MySQL file^[[0m
2015-02-14 11:06:24,563 (INFO) ee : ^[[94mAdding repository for Nginx^[[0m
2015-02-14 11:06:24,563 (DEBUG) ee : ^[[95mRunning command: add-apt-repository -y 'ppa:rtcamp/nginx'^[[0m
2015-02-14 11:06:25,680 (DEBUG) ee : ^[[95mAdding ppa of Nginx^[[0m
2015-02-14 11:06:25,680 (INFO) ee : ^[[94mAdding repository for PHP^[[0m
2015-02-14 11:06:25,680 (DEBUG) ee : ^[[95mAdding ppa for PHP^[[0m
2015-02-14 11:06:25,680 (DEBUG) ee : ^[[95mRunning command: add-apt-repository -y 'ppa:ondrej/php5'^[[0m
2015-02-14 11:06:26,833 (DEBUG) ee : ^[[95mUnable to execute command add-apt-repository -y 'ppa:ondrej/php5'^[[0m
2015-02-14 11:06:26,833 (DEBUG) ee : ^[[95m'ascii' codec can't decode byte 0xfd in position 281: ordinal not in range(128)^[[0m
2015-02-14 11:06:26,834 (ERROR) ee : ^[[91mError occurred while executing command^[[0m

#2

@seyntjim, We have fixed this error, we are also fixing more same types or error in EE 3.0.2, Hope we will release EE 3.0.3 soon


#3

Thank you! :slight_smile:


#4

Hi @seyntjim

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#5