Error displaying maps using WP GPX Maps


#1

Hi, I’m moving my sites on a Linode server from Apache to Nginx using ee.

However, I’m having a problem displaying maps.

I have a site: cycleguides.ca using Apache (and W3 Cache). It uses the WP GPX Maps plugin and displays maps OK. And I use the plugin as downloaded. That is, I haven’t added any Google Maps API key anywhere.

So I want to move the site to nginx but first am testing with a small site. It’s janaki.ca

Now when I use janaki.ca it gets an error on the maps. Same Wordpress plugin, WP GPX Maps. The page shows the frame with the following error.

“Sorry! Something went wrong. This page didn’t load Google Maps correctly. See the JavaScript console for technical details.”

And inside the browser error console the following error is indicated

Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error

When the page loads it looks like the maps try to load and then quickly disappear and the error text shows in the box. But as I noted, on my other site, cycleguides.ca using WP GPX Maps, I don’t have any problem.

FYI, my install used EasyEngine full stack install and the

  • Single-WordPress, Nginx’s fastcgi-cache

My bet is the problem is related to how the javascript is loaded and cached on the site, but to debug this I don’t know where to start!

Any help is appreciated!

FYI, nginx is FAST so far! I just need these maps to work on the nginx site so I can port over my cycleguides site and also get my other old site, misterian.com onto nginx.

THANKS! And hopefully as I learn more I can contribute to this forum and the EasyEngine intitiative!


#2

I am going to answer my own post here. I went into the code for the WP GPX Maps plugin and editied the google maps api key loading to add in the API. And now it works. Strange that it worked on Apache with out the api key but if it works it works.

Cheers!


#3

It’s a known issue Google stopped allowing to use maps without API keys


#4

@misterian Glad that the issue was resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#5