Error creating git repository via Source tab


#1

When creating a new repository via a project’s Source tab, I get the error message “Failed to load page. Please try again later.” Browsing away to the home page, and then back to the Source tab gives the same error message.

In Administration > Gitolite Settings, I am able to see the repository in the list. Clicking on the repository name brings me to a page displaying the commands for creating the new repository. I was able to also remove the repository.

Turning on debug mode in AC, I was able to see the following error instead of the “Failed to load page” error:

Fatal error: Call to undefined method ProjectSourceRepository::getDefaultBranch() in /path/to/domain/compile/83f4ed93ddf89d259916528f9f0baaabad39f71c.file._repository_row.tpl.php on line 46

I’m using activeCollab-gitolite on AC 3.1.19 / PHP 5.3.

I currently have no clue how to workaround this issue. Any help would be much appreciated. Thank you!


#2

Can you please try to clear all cache and compiled template ?

AC 3.1.19 is very old version of ActiveCollab, I suggest you to upgrade it.


#3

I've tried clearing cache and compiled templates, but the issue remains.

Is this version of ActiveCollab not supported? Because I can't find any mention of 3.1.19 not being supported. It's not possible for us right now to upgrade to AC4.


#4

Hi @Ron,

I sent you a mail regarding issue with download link of older version of ac-gitolite might solve your issue as your ac version is too old.


#5

Hi Faishal,

Thanks for your help getting me on the older version of ac-gitolite. The v1.0 version did work well.

However, after reviewing the situation, we have decided to upgrade to AC4, so that we can take advantage of the newer features in ac-gitolite as well.

Appreciate your prompt support!


#6