Error: could not find driver - issue on fresh install / Ubuntu 16.04

Hey guys,

I’m kinda getting out of any solutions to think of, so I’m writing here:

I want to install a fresh easyengine instance on a VM with Ubuntu 16.04.
I tried installing directly with the wget -qO ee && sudo bash ee script, also tried on a new instance with PHP 7.2 installed.

Getting the same message when trying to access any ee site command:
Error: could not find driver

Any ideas to fix this?
Should I try 14.04 or 18.04?

The VM is set up in Microsoft Azure if it helps.

Thanks in advance!

Just taking a stab here. I know that EE is very PHP version specific. I would check the php version installed and maybe even check which php versions are available on the server. I would go with v7.2 at the least and maybe v7.4 if available. i forget what is available in the 16.04 repos.

I do have a question. Why 16.04 and not 18.04 or 20.04? You will always get the latest versions of packages in the repos with newer server versions and you don’t have to wait for developers to backport their packages to older server versions. Plus 16.04 is End Of Life April 2021.

So if you can use 18.04 or 20.04 I bet your issues go away. I have been rolling out VPS with 20.04 and with the exception of a single instance of having to roll a system PHP v8 back to v7.x I have not had any issues.

Try the following to check PHP versions:

php -v to show which version is running

sudo update-alternatives --display php to show available packages

sudo update-alternatives --update pho to change the default system version of PHP.

Hope something here helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.