Error 500 fc + w3tc


#1

Hello nice community! :slight_smile: I have an error on a client site after updating w3 total cache just a moment ago.

The site was installed using wpfc command, and also has the w3 total cache which I believe was installed by default. I use memcached for caching resources (from w3tc). Everything was working fine, but suddenly after updating w3 plugin, the site started to give me HTTP 500. I also updated the wordfence security plugin at the same time. But I noticed the problem is W3 since I renamed the plugin folder and the site now works. However, I’d like to have W3 working again, since it’s a site with too many visitors.

Does anybody know what could be?

Thank you.


#2

This is an issue with w3tc, they released a crap update the broke a lot of stuff. To solve your issue as quickly as possible copy the db.php file from /wp-content/plugins/w3-total-cache/wp-content and replace the current one located in the /wp-content directory. That should solve the HTTP 500 issue, after which you should log into your site, turn off all the caching options and frankly remove the plugin till they fix it. Looking at the updates tracker they haven’t done any actual updates since 2014 and the most recent update was to stop a known XSS vulnerability with w3tc but they broke a ton of stuff in the process.

Personally I feel it might be time for easyengine to remove w3tc as an option and provide a better alternative. I have been testing with a fresh site and the same issue occur since the wordpress setup script installed w3tc even when you pick fastcache.

Here is a walkthrough on how to totally remove w3tc from your site so you wont have any furture issues. http://www.kentooz.com/remove-w3-total-cache-manually/


#3

Thanks @Code_Bear for your answer. I already deleted the plugin.

I posted it here, because I thought it may be an issue to solve for EE. However, seeing that W3 did almost nothing in the last updates, except for the XSS vuln. it may be good for EE to get rid of W3 and look for an alternative.

Thanks again!


#4

I agree, I was actually writing a post calling for EasyEngine to stop using W3TC hoping they will remove it from their install commands. I personally use the fastcgi_cache install which installs W3TC by default but now I can’t even setup a fresh install without having to go through all the steps to remove W3TC from the site so I can use it. =/


#5

Wouldn’t WP-REDIS be a good replacement for WP-FastCGI, in your case?


#6

You would know better than me. lol I thought redis was more for big media like videos and the like. If it works better for standard wordpress sites I will have to check it out.


#7

Yes, I’m sure you want to take a look at REDIS. :slight_smile:

I’ve been replacing WPFC and W3TC with WPREDIS for a while, and it is all joy and happiness.

You just gotta take care of two details: after update the site to WPREDIS you must run wp redis enable in its htdocs directory in order to activate object caching; and in wp-config.php you should move the “salt” EE appends to the end of the file to the beginning, in order to avoid conflicts in case of multiple domains in same server.


#8