Error 404 after deleting force-ssl.conf


#1

Hi! I am a new user and really loved the way you have made managing vps easy for new linux users like me.

I was using this tutorial to get letsencrypt ssl install.

I created the forced ssl configuration as directed. When I reloaded nginx website is not showing and giving a 404.

So I deleted the forced ssl conf file and reloaded the ngix now, when I open the domain its taking me to a Nginx default page.

What to do…


#2

I resolved the issue by rolling back the changes made to ssl.conf When I ran “request for SSL from Let’s Encrypt” command as directed by the page, it gave a fine result.

But now, when I am trying to renew certificate its giving an error.

Is this error caused due to Cloudflare. Because its showing cloudflare IP.

Do you have any tutorial to configure lets encrypt when the people are using Cloudflare to manage DNS


#3

When you are behind CloudFlare you should use CloudFlare’s Flexible SSL, not Let’s Encrypt.


#4

Thanks for confirming! There were some misguiding tutorial online that were saying that Cloudflare and Lets Encrypt will work together. But After searching a lot I discovered that Lets Encrypt will not work with Cloudflare’s Free plan. You can only encrypt the whole connection if you have Cloudflare Premium.


#5

Hii web.techj

When you are requesting SSL Certificate from Let’s Encrypt, please bypass cloudflare.

And after successfully fetching ssl certificate from LE enable cloudflare Full or Strict SSL only.

Cloudflare Flexible SSL would provide redirect loop if site is running on https:// on server.

Also please note from above configuration, end user would only see the ssl given by cloudflare.


#6

@Prabuddha

Thanks for update. Should I use Namecheap DNS hosting.

Will then Letsencrypt work fine.


#7