Error -1 when edit the uploaded image


#1

Dear All,

I like this plugin, but I found a problem when update the existing image (use modify image button) that already uploaded in the media album area, it's show a "-1" text after I click the "update" button. Also, if I use MS Internet Explorer (version 10) browser, I can't upload the image. Please advise. Thank you.


#2

@veedub-veedub - We are using the default WordPress image editor for this, and WordPress does not allow users with role Subscribers to edit images. Although we have plans of getting this sorted, for now you would need to elevate the default role of users to Contributor to solve this issue.


#3

Ok, thank you for your help and quick response. I will try it to elevate the role as per your advise. How about the IE browser issue? Thank you so much.


#4

@veedub-veedub - We have tested the uploader in IE 10 on our demo site and it works fine. Make sure there are no plugins or theme js conflicting with it.


#5

@veedub-veedub - We have tested the uploader in IE 10 on our demo site and it works fine. Make sure there are no plugins or theme js conflicting with it.


#6

What is the easy way to check whether there are plugins or theme js that conflicting with this plugin? Should I try to deactivate one by one or there are a tools to check it? Thanks,


#7

@veedub-veedub - You could first try deactivating all the plugins except rtMedia and BuddyPress and check if it then works. If it doesn't, then try switching to the default theme.

If it works after deactivating all the plugins, you should check them by re-activating your plugins one by one and checking who the culprit is.


#8

ok, thank you so much


#9

#10

#11