ERR_TOO_MANY_REDIRECTS - URGENT response needed please

Hi team,

I’m experiencing this error and I don’t know what to do.
The site worked fine until I applied letsencrypt on it.

| OS | Linux 4.15.0-58-generic #64-Ubuntu SMP Tue Aug 6 11:12:41 UTC 2019 x86_64 |
| Shell | /bin/bash |
| PHP binary | /usr/bin/php7.2 |
| PHP version | |
| php.ini used | /etc/php/7.2/cli/php.ini |
| EE root dir | phar://ee.phar |
| EE vendor dir | phar://ee.phar/vendor |
| EE phar path | /var/lib/docker/volumes/global-nginx-proxy_certs/_data |
| EE packages dir | |
| EE global config | /opt/easyengine/config/config.yml |
| EE project config | |
| EE version | 4.0.14 |

I tried configuring it via cloudflare and I was getting ERR_TOO _MANY_REDIRECTS but then I got rid of cloudflare and now is pointing to my hosting DNS… the IP is set correctly all points great

DNS looks fine:
Points to server IP fine:

Redirect Check:

HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Thu, 05 Sep 2019 12:07:11 GMT
Content-Type: text/html
Content-Length: 178
Connection: keep-alive
X-Powered-By: EasyEngine v4.0.14

It shows 19 - 301 redirects lol…
What am I doing wrong guys please help, it’s urgent.

Turn off CloudFlare proxy temporarily (change from Orange to Grey). Wait for the DNS to change to your server ip address. Login and make sure WordPress is set to HTTPS:// (Not HTTP://) in Settings/General. This has fixed that issue for me several time. Also check Cloudflare SSL mode. It should be Full (Strict) if you have a certificate for the site on your EE server.