Enabling ftp_connect, ftp_login, ftp_nb_fput


#1

I installed UpdraftPlus Backups plugin which offers uploading your wordpress backup to remote location via FTP. However, I am getting this when I go to FTP backup option of UpdraftPlus.

Warning: Your web server’s PHP installation has these functions disabled: ftp_connect, ftp_login, ftp_nb_fput. Your hosting company must enable these functions before regular non-encrypted FTP can work. I used following command to install wordpress on my server. ee site create mywebsite.com --wpfc --hhvm

How do I enable ftp_connect, ftp_login, ftp_nb_fput. I couldn’t find such option in /etc/php/5.6/fpm/php.ini


#2

So I resolved it myself by support from another forum. Here’s how to resolve in case anyone else is face this issue.

Add hhvm.enable_zend_compat = true into /etc/hhvm/server.ini and then restart hhvm by service hhvm restart

The issue is basically because I created wordpress site using hhvm instead of php.


#3