Enable SSL


#1

I followed the instructions https://easyengine.io/wordpress-nginx/tutorials/ssl/comodo/ to install SSL. I am using Gandi Standard SSL. After installation I analyzed SSL using https://globalsign.ssllabs.com/, which gave positive result. However, when I enable SSL by changing URL in settings>general to https://example.com site was unable to use SSL and doesn’t load. I also used

define(‘FORCE_SSL_LOGIN’, true); define(‘FORCE_SSL_ADMIN’, true);

in wp-config.php, but didn’t work. Apart form this, after modifying wp-config.php wp-admin was not working. How to fix?


#2

Have your reload the nginx configuration ? nginx -t && service nginx reload

To resume the configuration : in /var/www/yourdomain.com/conf/nginx/ssl.conf

   listen 443 ssl http2;
    ssl on;
    ssl_certificate     /pathtoyourcertificate.crt
    ssl_certificate_key    /parthtoyourprivatekey.pem; 

in /etc/nginx/conf.d/yourdomain-force-ssl.conf

	server {
	listen 80;
	server_name yourdomain.com;
	return 301 https://yourdomain.com$request_uri;
}

Then make sure your wordpress url use https, for that you can change it in phpmyadmin, in the table wp-options.


#3

Thanks virtubox:slight_smile:


#4