Enable SSL (letsencrypt) for only to be used on checkout page


#1

I used ee site update example.com --letsencrypt to enable ssl for a site but that converts the site to ssl as well. Is there any way to just enable ssl but keep using HTTP ?

I only want to force ssl for the checkout page (woocommerce)


#2

Remove the force ssl file at /var/www/[stie-name]/config/

Then in woocommerce setting > checkout >check for SSL on checkout page.

However I would highly recommend using SSL on your whole site. It improves SEO scores and helps prevent malicious attacks and phishing scams using your site. Unless you have a specific problem force it.


#3

I can’t find any force file in that directory, but I can find a force file at

/etc/nginx/conf.d/force-ssl-thedomain.com.conf

I deleted that but still the site is getting redirected to https. I tried changing the site url from wordpress settings to be non https but it reverts back to https on save.

Any ideas?


#4

Been looking around and there is no easy way to do this? Can someone help?


#5

There is now easy way to do it. I think no one here will be able to help, unfortunately.


#6

Figured it out.

Just delete the force-ssl-domain.com.conf file from /etc/nginx/conf.d

And then goto /etc/nginx/sites-available and open the config filed named just domain.com from the directory and add listen 80; after server {

Restarted server, cleaned cached and it all worked fine after that. Http and Https both with http as default.


#7