Enable admin-tools error


I get error when trying to enable admin-tools:

ee admin-tools enable mysite.com
Global auth exists on admin-tools. Use ee auth list global to view credentials.
Installing pma
PHP Fatal error: Uncaught Error: Class ‘ZipArchive’ not found in phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php:226
Stack trace:
#0 phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php(289): Admin_Tools_Command->extract_zip(’/tmp/pma.zip’, ‘/tmp//pma’)
#1 phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php(67): Admin_Tools_Command->install_pma(Array, ‘/opt/easyengine…’)
#2 phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php(122): Admin_Tools_Command->install()
#3 [internal function]: Admin_Tools_Command->enable(Array, Array)
#4 phar:///usr/local/bin/ee/php/EE/Dispatcher/CommandFactory.php(96): call_user_func(Array, Array, Array)
#5 [internal function]: EE\Dispatcher\CommandFactory::EE\Dispatcher{closure}(Array, Array)
#6 phar:///usr/local/bin/ee/php/EE/Dispatcher/Subcommand.php(272): call_user_func(Object(Closure), Array, Array)
#7 phar:///usr/local/bin/ee/php/EE/Ru in phar:///usr/local/bin/ee/vendor/easyengine/admin-tools-command/src/Admin_Tools_Command.php on line 226

Any input on this issue is appreciated.

Can you share the output of

  1. ee cli info
  2. lsb_release -a
  3. docker info

Here is the output:

ee cli info

| OS | Linux 4.15.0-42-generic #45-Ubuntu SMP Thu Nov 15 19:32:57 UTC 2018 x86_64
| Shell | /bin/bash
| PHP binary | /usr/bin/php7.2
| PHP version | 7.2.12-1+ubuntu18.04.1+deb.sury.org+1
| php.ini used | /etc/php/7.2/cli/php.ini
| EE root dir | phar://ee.phar
| EE vendor dir | phar://ee.phar/vendor
| EE phar path | /var/lib/docker/volumes/global-db_db_conf/_data
| EE packages dir |
| EE global config | /opt/easyengine/config/config.yml
| EE project config |
| EE version | 4.0.4

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

docker info

Containers: 7
Running: 7
Paused: 0
Stopped: 0
Images: 8
Server Version: 18.09.0
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: c4446665cb9c30056f4998ed953e6d4ff22c7c39
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: fec3683
Security Options:
Profile: default
Kernel Version: 4.15.0-42-generic
Operating System: Ubuntu 18.04.1 LTS
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 2.795GiB
Name: wpstage03
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false
Product License: Community Engine

WARNING: No swap limit support

any fix to this issue?
i experienced the exact same problem