EEv4 Mac - Upload stuck at 2mb


#1

Hi

I tried to :

  • edit /config/php/php/conf.d/custom.ini
  • add @ini_set stuff in my functions.php (I know, I know…)

no chance to see the value move nor to upload anything more than 2MB


#2

Also tried to edit /usr/local/etc/php/7.2/php.ini

Restarted local PHP with : brew services restart php

Reloaded website using ee site reload

Still no chance


#3

i got same problem with php.ini like you.

I cannot take affect with php.ini


#4

@pserafini @mrgozvn After editing ~/easyengine/sites/example.com/config/php/php/conf.d/custom.ini, you need to restart PHP with ee site restart --php.

Actually even reloading PHP with ee site reload --php would do, but reloading PHP is broken and will be fixed in next release.


#5

in my case. my command
ee site restart example.com --php

its not work :frowning:


#6

I found a workaround to upload bigger files using the Upload Max File Size plugin
(still can’t explain why this one makes it work, when everything else fails)
But then I run into another issue :
Once my file is finished loading, I get a 413 - Request Entity Too Large Error
I tried to increase nginX client_max_body_size AND increase PHP memory_limit, upload_max_filesize and post_max_size.
Restarted both services too.
Still not working.


#7

Hi everyone !

Still can’t get rid of this 413 error, even after editing the nginx config files AND restarting both services AND Docker itself

Can you help ?


#8

BUMP :smiley:


#9

Hello, you still has no fix 4 this ?
i have same problem, client_max_body_size, memory_limit, upload_max_filesize, post_max_size = 512M
Still can’t load backup through wp migrate plugin


#10

Hi there, any updates on this???


#11

There is some kind of issue on the MacOS version. I tried to replicate this issue and found it to be still true in the latest release 4.0.9.

We’ll work on this. You should expect a fix in the coming week.


#12

Not only Mac OS version, Ubuntu too


#13

BUMP :smiley:


#14

:point_up::point_up::point_up: BUMP


#15

@kirtan could you help us here please ?

This simple bug prevents me and probably others from using ee4 desktop and build automatic deployment from local to production. I think it’s too bad for such a great featured to be locked because of bugs such as this one.

Thanks for everything anyways.

p.


#16

@pserafini We’ve identified the issue and are working on it. In my estimation the issue should be solved by next release.


#17

Any update on this? I have been stuck for a while


#18

:pleading_face: