EE4 breaks with Yith Affiliate pro plugin (other hostings not)

Anyone using Yith Affiliate Pro plugin will not benefit from using it on a server with EE.

I tested it all on fresh Serverpilot, Siteground hosting and local WinNMP: things only break with EE.

The problem lies within settings. Once the plugin is activated, and once you start saving options, things break.
Options are saved once, or twice. But after that you can try to change the settings as many times you want, but nothing will be changed until you sudo reboot.
After that the settings can be changed once or twice again, and everything stops working again.

I also experienced that some plugins such as Woocommerce did not want to deactivate. I had to run phpmyadmin to run a query and turn InnoDB to MyISAM to recreate and fix the tables, after which the deactivating/activating plugins worked properly again.
But Affiliate plugin never worked correctly, even after doing multiple repairs or reconstructions in db.

I recreated the whole thing from the ground-up on default wp theme, only with woocommerce and yith plugin. The same thing happened again.

I accidentally discovered that, once migrated the whole website to local environment, everything worked just fine.
Then, I restored the website copies to serverpilot, and shared hosting on Siteground: Everything worked fine.

I did try to create fresh servers with more resources and run them with ee, but I got the same results. I do know that ee is missing some php modules required by wordpress (recommended) which might be the problem.

This is the first unsolvable problem for me with EE.
I guess I will migrate the website to Serverpilot.

ee doesn’t work with any Affiliate plugin correctly. Once installed and activated, plugins can’t save options once you change them after 2nd time.
Thoroughly tested on fresh servers with default theme, woocommerce and AffiliateWP or Yith Affiliate Premium.
EE - doesn’t work
Serverpilot - works (no redis)
Ploi - works (no redis)

Next test will be when I configure Redis on SP.


Once I installed and configured Redis server (and php redis module) and WordPress plugin to connect wp with redis, the plugins (both AffiliateWP and Yith Affiliate Premium) had the same problem as described in initial post.

The problem is in Redis, not just on EE, but everywhere.

However, I did not experience the problem on Memcached which is used by Siteground.

EE/Serverpilot/Ploi/Anywhere : WORKS (no Redis object cache)
EE/Serverpilot/Ploi/Anywhere : DOESN’T WORKS (with Redis object cache)

Use memcached for object cache if you use Affiliate plugins with WordPress.
Flush Redis cache every time
Test with local Redis EE setup (not shared)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.