EE4 - access in the /opt/easyengine/sites/example.com/app directory - /app/htdocs - EE4

Good afternoon, I’m annoyed with the EE4 service, I have not been successful since the EE3 version. Very frustrating to now, in the client, in many sites, full on the site, in many sites, full page, by several times. Still, there are difficulties for the present in this project.

Please, I will ask for help, but also help those who can help, who can post correct information, otherwise do not waste your time.

Dispensing achism!

I installed on the ubuntu instance 18.04 on the Digital Ocean server. I installed EE4 Easyengine 4.0.

I created a Wordpress website.

In Easy Engine 3 the sites were in the directory / var / www /
NO Easy Engine 4 sites are in the / opt / easyengine / sites /

The wordpress files are inside the folder /example.com/app/htdocs/

I can not access the directory / app / or app / htdocs /

Please contact me, I can not access the / app / directory via FileZilla.

in print you can see that the app folder has a link icon, as if referring to another directory.

I know Vagrant / Homestead uses the one file to reference from one directory to another, mirroring.

But I can not find anything that makes sense in the forums.

Does anyone have a solution to solve this? Anyone know how to resovler?

Can someone tell me how that part works in EE4.

Please, please give a soution, explain in detail, otherwise you do not have to say anything!

First attempts to give tips and solve badly resolved.

Please, can anyone help me ???

Are you using root user or non-root? Non-root won’t work currently. See: https://github.com/EasyEngine/easyengine/issues/1340

I’m having the same issue. What’s the correct way to give root permissions to another user for this case?

I need to access via Filezilla as well with a SSH Key. I’ve tried changing the permission, adding users to groups, giving read and write permissions. I tried to force it but still I’m unable to access the app folder.

I’m using EE4 Debian 8 on GCP, Fresh install. Everything else seems to working.

Thank you guys for creating EE :slight_smile:

The easiest way to access the correct folder via SFTP is edit the path and type /opt/easyengine/sites/domain.com/app/htdocs it will open docker volume directory.
So only app has the issue with root:root. Rest all just works fine.

Friend, thank you for your help, for your willingness to help me, but I did not understand your explanation.

Also give execute permissions to /var/lib/docker/volumes, as shown in example below:

chmod g+x /var/lib/docker/volumes
chgrp www-data /var/lib/docker/volumes

Use whatever group makes sense for you, eg. sftpuser