EE.v4 How to Update / Install SSL After Installing Domain Without SSL?


#1

Hello, I’ve already installed a wordpress site without SSL. Now, I’m trying to install SSL but getting error. Moreover, I’ve not found any command like v3 : “ee site update domain.com --letsencrypt” to setup SSL (LetsEncrypt).

In version 4 I’ve not found any option to install / update SSL after installing a domain. Is there any way to do it? Please, Share with example command.

Thanks!


#2

I believe this was discussed elsewhere. ee site update is not implemented yet. Backup the site, re-created it with ssl=le and restore.


#3

@mamunagni Currently ee site update is has not been added in v4. It will be added in upcoming releases. Please backup and recreate site as @mram said.

Sorry for the inconvenience caused.


#4

Hi! Same issue here for me, will start with non-SSL and add SSL later. Because for some reason on fresh EE4 install on lightsail, site with SSL times out, whereas non-SSL site runs fine. Not sure why.

As busy as I know you guys are … any idea on possible timetable for the ee site update? Thanks!


#5

+1 on this being a big issue.

Because of the LE certificates being DNS-based authentication, it means that to build a new version of a site that’s running elsewhere, you need to re-point DNS and take the existing site offline.

There needs to be a way to add an SSL to a site. I’m trying to move a handful of sites from a different server, and would normally deploy the new site, backup the old site, restore the backup onto the new site, test it, then once it’s working, change DNS and then add the SSL cert. This is how I deployed many sites to a v3 server.

@kirtan - any ETA for this functionality? I can’t start using v4 until this works, and I’m sure that’s going to become a hurdle for many people.

Thanks!
And keep up the fabulous work!

David.


#6

+1 on this topic


#7

This is the only feature which is holding me back from upgrading to v4.


#8

@tamhas @davidsandbrand @Davide_Prevosto @Prateek_Mishra It should be added in EE by End of December :slight_smile:


#9

@kirtan Glad to hear it’s on the shortlist. Not quite as short as I was hoping, given that support on ee3 is already limited, but so be it.

Thanks.


#10

good to hear!! thanks


#11

ee site update <site-name> --ssl=le should work now. It has been released in EasyEngine v4.0.6.

Run ee cli update to update to the latest version.


#12

Enjoying the steady diet of EE awesome


#13

Thanks @mrrobot47 - Worked a treat for me.

ee cli update

ee site update <site-name> --ssl=le

Does anyone know how to add redis caching onto a site that doesn’t previously have it using the update command? The ones I have tried don’t currently work.

Thank you.


#14

Thanks @mrrobot47!
Thanks @kirtan!


#15

ee site update is being rolled out at as it is being developed. Enabling caching to a non-cached site is a part of ee site update and will be rolled out soon. You can track progress of ee site update here: https://github.com/EasyEngine/site-command/issues/116


#16

Thanks for your kind reply :slight_smile:


#17

Thanks @jkdste I will try soon :slight_smile: