EE update and git commit failed


#1

Hi

I am experiencing a series of problems which are probably related (logged in as root):

  1. if I run ee update, I get error unable to download file, /tmp/eeupdate…

  2. If I run ee site info www.site.com, it shows SSL as disabled, DB_NAME, DB_USER and DB_PASS as deleted. however, the site exists, and SSL is enabled

  3. I need to renew Letsencrypt, but if I run ee site update www.site.com --le, I go through the questions, the certificate updates successfully, but I get error Unable to git commit at /etc/nginx

The error log :

2018-05-23 16:08:41,595 (DEBUG) ee : e[95mEEGit: git commit at /etc/nginxe[0m
2018-05-23 16:08:41,633 (DEBUG) ee : e[95m

 RAN: '/usr/bin/git --git-dir=/etc/letsencrypt/.git --work-tree=/etc/letsencrypt --git-dir=/etc/nginx/.git --work-tree=/etc/nginx commit -am Adding /etc/nginx/conf.d/force-ssl-v2.webtransformations.biz.conf'

STDOUT:
On branch master
Changes not staged for commit:
	e[31mmodified:   letsencrypte[m (untracked content)

no changes added to commit


  STDERR:
e[0m
2018-05-23 16:08:41,634 (ERROR) ee : e[91mUnable to git commit at /etc/nginx e[0m 

Help anyone?


#2