EE unable to create database


#1

root@server:/var/www# ee site create test --mysql

Running pre-update checks, please wait… Setting up NGINX configuration [Done] Setting up webroot [Done] Setting up database Oops Something went wrong !! Calling cleanup actions … Reload : nginx [OK] Check logs for reason tail /var/log/ee/ee.log & Try Again!!!

/var/log/ee/ee.log

2017-03-03 12:46:39,510 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2017-03-03 12:46:39,865 (DEBUG) ee : [’/usr/local/bin/ee’, ‘site’, ‘create’, ‘test’, ‘–mysql’] 2017-03-03 12:46:39,865 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fb3020e6860> 2017-03-03 12:46:39,868 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7fb3020e6f98> 2017-03-03 12:46:39,871 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteCreateController object at 0x7fb3020f4400> 2017-03-03 12:46:39,877 (INFO) ee : Initializing EasyEngine Database 2017-03-03 12:46:39,888 (DEBUG) ee : Setting apt_packages variable for Nginx 2017-03-03 12:46:41,958 (DEBUG) ee : Finding string SCRIPT_FILENAME to file /etc/nginx/fastcgi_params 2017-03-03 12:46:41,959 (DEBUG) ee : Setting apt_packages variable for PHP 2017-03-03 12:46:44,026 (DEBUG) ee : Setting apt_packages variable for MySQL 2017-03-03 12:46:44,027 (DEBUG) ee : Running command: mysqladmin ping 2017-03-03 12:46:44,082 (DEBUG) ee : Command Output: mysqld is alive , Command Error: 2017-03-03 12:46:44,083 (DEBUG) ee : Setting apt_packages variable for Postfix 2017-03-03 12:46:46,154 (INFO) ee : Running pre-update checks, please wait… 2017-03-03 12:46:46,154 (DEBUG) ee : checking NGINX configuration … 2017-03-03 12:46:46,321 (INFO) ee : Setting up NGINX configuration 2017-03-03 12:46:46,321 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache 2017-03-03 12:46:46,325 (DEBUG) ee : Checking generated nginx conf, please wait… 2017-03-03 12:46:46,489 (INFO) ee : [Done] 2017-03-03 12:46:46,489 (DEBUG) ee : Creating Symbolic link, Source:/etc/nginx/sites-available/test, Dest:/etc/nginx/sites-enabled/test 2017-03-03 12:46:46,489 (INFO) ee : Setting up webroot 2017-03-03 12:46:46,490 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/test.access.log, Dest:/var/www/test/logs/access.log 2017-03-03 12:46:46,490 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/test.error.log, Dest:/var/www/test/logs/error.log 2017-03-03 12:46:46,490 (INFO) ee : [Done] 2017-03-03 12:46:46,664 (INFO) ee : Setting up database 2017-03-03 12:46:46,665 (DEBUG) ee : Creating database test 2017-03-03 12:46:46,667 (DEBUG) ee : 2017-03-03 12:46:46,668 (DEBUG) ee : ‘MySQL Connectivity problem occured’ 2017-03-03 12:46:46,906 (INFO) ee : Oops Something went wrong !! 2017-03-03 12:46:46,906 (INFO) ee : Calling cleanup actions … 2017-03-03 12:46:46,907 (DEBUG) ee : Removing Nginx configuration 2017-03-03 12:46:46,907 (DEBUG) ee : Removing /etc/nginx/sites-enabled/test 2017-03-03 12:46:46,907 (DEBUG) ee : Removing /etc/nginx/sites-available/test 2017-03-03 12:46:46,907 (INFO) ee : Reload : nginx
2017-03-03 12:46:47,077 (INFO) ee : [OK] 2017-03-03 12:46:47,097 (DEBUG) ee : Removing /var/www/test 2017-03-03 12:46:47,097 (DEBUG) ee : Removing /var/www/test 2017-03-03 12:46:47,106 (ERROR) ee : Check logs for reason tail /var/log/ee/ee.log & Try Again!!!

root@server:/var/www# lsb_release -a

No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.5 LTS Release: 14.04 Codename: trusty

root@server:/var/www# ee -v

EasyEngine v3.7.4 Copyright © 2016 rtCamp Solutions Pvt. Ltd.

root@server:/var/www# ee -v

EasyEngine v3.7.4 Copyright © 2016 rtCamp Solutions Pvt. Ltd.

root@server:/var/www# ee info

NGINX (1.10.0):

user www-data worker_processes auto worker_connections 4096 keepalive_timeout 30 fastcgi_read_timeout 300 client_max_body_size 100m allow 127.0.0.1 192.168.3.0/24

PHP (5.6.30-1):

user
expose_php Off memory_limit 128M post_max_size 8M upload_max_filesize 2M max_execution_time 30

Information about www.conf ping.path /ping pm.status_path /status process_manager ondemand pm.max_requests 500 pm.max_children 100 pm.start_servers 20 pm.min_spare_servers 10 pm.max_spare_servers 30 request_terminate_timeout 300 xdebug.profiler_enable_trigger off listen 127.0.0.1:9000

Information about debug.conf ping.path /ping pm.status_path /status process_manager ondemand pm.max_requests 500 pm.max_children 100 pm.start_servers 20 pm.min_spare_servers 10 pm.max_spare_servers 30 request_terminate_timeout 300 xdebug.profiler_enable_trigger on listen 127.0.0.1:9001

MySQL (10.1.21-MariaDB) on localhost:

port 3306 wait_timeout 600 interactive_timeout 28800 max_used_connections 5 datadir /var/lib/mysql/ socket /var/run/mysqld/mysqld.sock my.cnf [PATH] /etc/mysql/conf.d/my.cnf

root@server:/var/www# wp --allow-root --info

PHP binary: /usr/bin/php7.0 PHP version: 7.0.15-1+deb.sury.org~trusty+1 php.ini used: /etc/php/7.0/cli/php.ini WP-CLI root dir: phar://wp-cli.phar WP-CLI packages dir: WP-CLI global config: WP-CLI project config: WP-CLI version: 0.24.1

root@server:/var/www# ll /root/.my.cnf

-rw------- 1 root root 46 Jul 21 2016 /root/.my.cnf

root@server:/var/www# cat /root/.my.cnf

[client] user = root password = *****

The details are correct as seen here:

root@server:/var/www# mysql

Welcome to the MariaDB monitor. Commands end with ; or \g. Your MariaDB connection id is 3606


#2

Usually, when EE doesn’t create the new website correctly it is because WP-CLI is outdated.

If that’s the case, the command below can fix the issue:

wp cli update


#3

Thank you for the tip. I’ve updated WP-CLI and went from version 0.24.1 to 1.1.0. (never updates this before and apparently is not done in ee’s stack update)

This did not seem to change anything. Also I am not trying to create a wordpress site here. Just a PHP with MySQL (MariaDB) site. And it still fails on the creation of the database.


#4