EE + Ubuntu 18.04 LTS compatibility


#1

Hi guys, is it safe to use Ubuntu 18.04 for my VPS? Has anyone tried to run a website using EE + Ubuntu 18.04? Does it work?

UPDATE: Ohhh just got this error - EasyEngine (ee) only support Ubuntu 12.04/14.04/16.04 LTS and Debian 7.x/8.x


#2

+1


#3

Needs update…


#4

Having that error doesn’t mean it’s incompatible per se, it just checks for certain Ubuntu versions. You could edit a file (I forgot which one) to have it accept 18.04. But then you’re on your own until it’s confirmed it works for real.


#5

Its as you say.


#6

EasyEngine v3 will probably never be compatible with Ubuntu 18.04 LTS, because rtCamp team is working hard on EEv4 (I think the first release should be available soon, by looking on the tasks progress on Github).

Nginx-ee package isn’t available for Ubuntu 18.04 LTS, and isn’t going to be updated due the the huge amount of work required to maintain a package repository.


#7

@pearson1fied

Tested EE v3 with Ubuntu 18.04 LTS. You will find a Lots of things broken.

Tested in both testing and semi production instances. Not worth investing time in the configurations.

It will still take some time. My Expectancy is Q4 this year.

Correct.


#8