Ee site update php not working


I am using easyengine version 4.1.0

When I run command ee site update DOMAIN --php=7.4

I get the following error:

Starting php version update for: DOMAIN
Taking backup of old php config.
Starting site with new PHP version: latest. This may take sometime.
Enabling site DOMAIN.
Success: Site DOMAIN enabled.
Running post enable configurations.
Starting site’s services.
Success: Post enable configurations complete.
Updating php config.
Error: Failed to copy “phar:///usr/local/bin/ee/vendor/easyengine/site-command/templates/config/php-fpm/” because file does not exist.

I tried --php=latest also, no luck. Any ideas?


This is a bug. It will be fixed in 4.1.1, which will release soon.

The patch for this has already been applied and is present in the nightly build. Till new release happens, you can update to nightly. After the release, you can update and move to the next stable version.

To update to nightly:

ee cli update --nightly --yes

# then run the php update command
ee site update DOMAIN --php=7.4

Thanks for replying. I should have probably looked at github I imagine any bugs will be listed there under issues? Also once you upgrade a site to SSL there’s no option I can find to remove it. I still love using easyengine it saves me lots of time.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Yes, there is no option yet to remove SSL from a site. Only update from non-ssl to ssl is supported as of now. You can create a feature request for this here:

Also, EE v4.1.1 has been released. You can update to the latest stable version (which contains the fix for this issue) with the command:

ee cli update --stable --yes