EE broke current nginx site


#1

I used the two commands on the frontpage. I already had a website at website.xyz so I put in my site as blog.website.xyz and it didn’t seem to work. The first command seemed fine but the second command thew out an error saying it could not restart nginx. Can EE not work on subdomains like I tried to do?


#2

Run nginx -t to discover what’s preventing Nginx to start.


#3

EE does work with subdomains.

My guess would be you’ve probably got Apache installed and running (which will stop nginx starting up if it’s on the same port).

What does service apache2 status say?


#4

Have you fixed this problem or are still facing it? Have you stopped Apache service, check the ngnix status.

EE works with sub domains:

sub.abc.com

Sometimes upgrading or any dependency update could break up the installation.


#5

Thanks everyone for the help, I just wiped my VPS and started over, worked fine. I run another nginx site along side my wordpress site so nginx was already installed the first time. The second (when it worked) I installed EE first and then setup my second site with nginx.


#6