EasyEngine wordpress+multisite-subdomain+letsencrypt


#1

Please help me on

I have set up EasyEngine in my Ubuntu 16.04 LTS (Xenial Xerus) machine. And have successfully created multisite wordpress with subdomain. Then I have configured main domain multisite to get subdomain. Also pointed subdmain CNAME to main domain.

I can successfully browse main domain and subdomain over http.

The question here is when ever I try to update site with letsencrypt. I can only browse main domain it auto redirects to https. But subdomain does not redirect to https rather opens nginx default page over http. And I manually enter https://subdomain it opens the wordpress page.

What can I do to correct this issue? I have not used domain mapping for both case, will that make any difference?


#2

I’m running my website on Vultr.

And I was just intalled my WordPress Multisite + Subdomain and Letsencrypt. And whenever I’m trying to access my subdomain.mymainsite.com and subdomain1.mymainsite.com it opens Nginx Default Page.

Please support or help both of us!


#3

What was the exact sequence of commands you used to create your sites?

How is your DNS configured?


#4

Hi portofacil,

I’m new to networking or this kind of stuff, and I’m not sure how my DNS is configured, but here is my screenshot of my dns settings on my Vultr dashboard.

Screenshot DNS

When I was just install my multisite + subdomain without letsencrypt by executing this script: sudo ee site create myweb.com --wpsubdomain --wpredis. All things are working so fine, then I created new subdomain through my WP Multisite Dashboard called Unity, then I accessed unity.myweb.com, it’s worked.

But after update my site with --letsencrypt only my main website working, but then everytime I visit my subdomain it shows Nginx default page.

Thank You


#5

WP Multisite and Let’s Encrypt don’t work together because LE does not issue wildcard certificates.

What you want is currently impossible to achieve using the tools available in EasyEngine.

Install stand alone websites, and make sure you have DNS entries for subdomain.domain.com and www.subdomain.domain.com, both pointing to the same IP. Then it will work.


#6

Wow, I didn’t know that before. And it seems that you are the only one who’s helping me.

I thank you for this.

Okay what about issue ssl certificates on every subdomains? Such run this command /opt/letsencrypt/letsencrypt-auto certonly --webroot -w /var/www/idevangelist.com/htdocs/ -d idevangelist.com . -d unity.idevangelist.com -d gamedev.idevangelist.com -d android.idevangelist.com --email myemail@gmail.com --text --agree-tos ?


#7

That’s not how wildcard subdomains work in Nginx.

I insist you’d better install single standalone WPs on every subdomain. Listen to an elder guy (me). :slight_smile:


#8