Easyengine v4 migration issue

Hello all,

Today I use easyengine v3 to v4 migration tool. When I run " ./migrate.sh --dry-run --all", it automatically migrated only a one wordpress site. Then I again try to migrate my other sites one by one. Then it shows “EasyEngine 4 is already installed. Exiting migration script”.

On "/opt/easyengine/sites/ " directory only display that dryrun migrated wordpress site, other sites are located on easyengine default location.

However, when I use “ee site list” it only displays the dry run migrated WordPress site. So how do I properly migrate my other wordpress sites?

Earlier, when I use Easy engine v3 I used “nginx-ee” script for install additional modules.

Now when I use, “ee site create mydomain.com --type=wp” it shows “Error: Cannot create/start proxy container. Please make sure port 80 and 443 are free.”.

That means Easyengine v3 and v4 both are running on my server?

How do I fix this issue?

had the same issue. the “dry run” isn’t a dry run.

I couldn’t solve the issue and just wiped the server. I wish you better luck

1 Like

I have gotten enormous value from easyengine, and I love the software. However, the v3 to v4 migration script is incomplete, broken, and doesn’t work for any use case. I’m rewriting/debugging it.
I’m tinkering with the migration script right now and will update this post as I go.

  1. from testing and inspecting the code (helper functions, parse_args()) specifying a single site to migrate is ignored. Flags like --dry-run and --all are trapped, but the script does not seem to parse a site name, if specified, and will loop thru all installed websites.

  2. first time thru the migration loop, after message “Creating in EasyEngine v4” it throws:Error: EasyEngine requires minimum PHP 7.2.0 to run.
    That message is clear enough: ee version 4 requires php7.2. However the ee version 3 installation is only running php7.0

I haven’t considered how to upgrade the php to 7.2, I’m guessing it’s non-trivial, and could break my existing ee3 installation.

At this point, the ee v3 installation is now borked, and when I tried to use the remote server migration, it borked both installations.

Manual migration of files via rsync is starting to look like the only realistic way to complete this.

1 Like

Stop the Nginx that was installed from v3 then try the ee commands again.

It’s unbelievable… it’s posted on the ee site and this exact thing just happened to me. It only migrated the first site on the list, ignoring the other 4… any workarounds?!