Easyengine phpMyAdmin login ERR_SPDY_PROTOCOL_ERROR and Connection refused while connecting to upstream


#1

Hello all,

When I try to login to phpMyAdmin by using “https://xxx.xx.xxx.197:22222/”, it promotes the login popup window, after logging in it shows the following errors.

Google Chrome shows following error.

The webpage at https://xxx.xx.xxx.197:22222/ might be temporarily down or it may have moved permanently to a new web address.

ERR_SPDY_PROTOCOL_ERROR

Microsoft Edge shows following error.

The connection to the website was reset.

Error Code: INET_E_DOWNLOAD_FAILURE

When I use any web browser (including Chrome Deskop, Mobile, MS Edge) every web browser shows errors. Therefore, I don’t think this is a web browser data and cache issue. When I checked the CSF firewall, it allow the port “22222”.

When I checked the 22222.error.log file it shows following errors.

connect() failed (111: Connection refused) while connecting to upstream, client: xxx.xxx.xxx.127, server: , request: “GET /db/pma/ HTTP/2.0”, upstream: “fastcgi://127.0.0.1:8000”, host: "xxx.xxx.xxx.197:22222"

Other than the above error, there’s no any other errors in “22222.error.log” file.

Update!
This VPS has three WordPress sites and they use LetsEncrypt SSL and those sites run without any issue.

Update 2!

I started facing this issue after I enabled lets encrypt for Wordpress sites. So anyway to correct it?

Are there any way to fix this error?


#2

Hello @aka20,

solution is available here :


#3

Dear Virtubox,

Thank you for your quick reply. I forget to mention that, there’s 3 WordPress sites on this server, and they are running normally. Those 3 sites uses LetsEncrypt SSL. I never faced such an issue with these sites. So ssl cipher issue only affected this?


#4

The error ERR_SPDY_PROTOCOL_ERROR is commonly related to outdated nginx ciphers suites.


#5

I think I have the newer ciphers, Although, I have replaced newer ciphers, but not success. :frowning: Are there any other solution?


#6

I started facing this issue after I enabled lets encrypt for Wordpress sites. So anyway to correct it?


#7

Have you reloaded Nginx after ciphers update?


#8

Yes, after the changes made reloaded nginx.