Easyengine new version: Unable To Reload Nginx



Thanks again for this wonderful tool.

Since the new release, impossible to create a website on a fresh Digital ocean 512m droplet Ubuntu 12.04.

root@Fmycloud:~# ee site create littlebigfrog.me --wp --w3tc

Creating littlebigfrog.me, Please Wait…

Creating Symbolic Link For littlebigfrog.me

Creating htdocs & logs Directory

Creating Symbolic Link For Logs

Downloading WordPress, Please Wait…

Setting Up WordPress, Please Wait…

Installing Nginx Helper Plugin, Please Wait…

Installing W3 Total Cache Plugin, Please Wait…

Changing Ownership

Reloading Nginx Configuration, Please Wait…

[ Fri Jan 17 05:51:07 EST 2014 ] Unable To Reload Nginx

log is always like: ls: cannot access /etc/nginx/sites-available/littlebigfrog.me: No such file or directory

[ Fri Jan 17 05:00:34 EST 2014 ] e[31m Unable To Reload Nginx e[0m

ee first thing installed.

things were working prefectly before new release.

Am i missing something?

Thanks in advance for your support


Can you run the nginx -t command and paste the output here.
Also attach the /var/log/easyengine/install.log file for the debugging purpose


root@Fmycloud:~# nginx -t
nginx: [emerg] invalid parameter “46-65-28-158.zon” in /etc/nginx/common/acl.conf:8
nginx: configuration file /etc/nginx/nginx.conf test failed

(I recognize my static ip adress)

install log attached


It seems like you have added a wrong ip for /etc/nginx/common/acl.conf file
Please remove the line 46-65-28-158.zon from /etc/nginx/common/acl.conf

If your IP address is then replace that line with allow;

nginx -t && service nginx reload


Thanks a lot, working.

However, Acl.cong was generated by ee, no intervention form me.
could you explain briefly the issue? I suppose the problem will occur for new users of ee, which is again an incredible tool!

Thanks and regards


In latest ee we removed the /etc/nginx/common/allowed_ip.conf and put all the contents in /etc/nginx/common/acl.conf

allowed_ip.conf used to protect some easyengine location like phpMyAdmin but some users don’t have a static ip address.

acl.conf can protect same locations and give access by using ip address or http auth so the users who can not have a static ip can access the phpMyAdmin by using HTTP Authentications


Thanks a lot for the clarification.



You can add your ip address in /etc/nginx/common/acl.conf file
Suppose your ip address is then add your ip before the deny all; line like

deny all;