Easyengine 301 Loop on Let's Encrypt


#1

I have had several issues when enableing LE on a site. The last one I did had some security error that was unidentified. I disabeling LE fixed it. I reenabled and restarted the server and it worked fine.

Today, with a new site, I am getting a 301 loop. When visiting https://domain.tld I get a 301 to https://domain.tld. I have not restarted yet, I wanted to figure out what the problem is. I checked the nginx configs, cleaned the cache, and cleared browser caches.


#2

I am still having this issue after restart. There is nothing in the log for the site. There are log entries in the nginx log just showing the 301

`108.162.216.200 - - [02/Feb/2017:13:46:02 +0000] “GET /wp-admin/options-general.php?settings-updated=true HTTP/1.1” 301 178 “-” “Mozilla/5.0 (Linux; Android 6.0; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Mobile Safari/537.36”

If I disable LE it works fine. I changed the website URL to https in wordpress but no change.


#3

I could not do anything to fix this. I deleted the site and re added it. Then renewed the LE certificate. Now its working fine.


#4