Dpkg: error processing package libc6:amd64


#1

Hi !

I have a strange error. I’ve updated easyengine and now when I try to update the server, or even create a new site, I have this error :

root@ubuntu-512mb-fra1-01:~# tail /var/log/ee/ee.log Fetched 4,399 kB in 1s (3,695 kB/s) Setting up libc6:amd64 (2.19-0ubuntu6.9) ... sh: echo: I/O error dpkg: error processing package libc6:amd64 (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: libc6:amd64 E: Sub-process /usr/bin/dpkg returned an error code (1) 2016-06-27 10:40:50,777 (INFO) ee : Oops Something went wrong!! 2016-06-27 10:40:50,779 (ERROR) ee : Check logs for reasontail /var/log/ee/ee.log& Try Again!!!

I don’t know if it’s EE related but I can’t figure out what the problem is. Before doing the update, everything worked fine.

This is the result of apt-get update -f :

sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 84 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up libc6:amd64 (2.19-0ubuntu6.9) ...
sh: echo: I/O error
dpkg: error processing package libc6:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libc-dev-bin:
 libc-dev-bin depends on libc6 (>> 2.19); however:
  Package libc6:amd64 is not configured yet.
 libc-dev-bin depends on libc6 (<< 2.20); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc-dev-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 depends on libc6 (= 2.19-0ubuntu6.9); however:
  Package libc6:amd64 is not configured yet.
 libc6-dev:amd64 depends on libc-dev-bin (= 2.19-0ubuntu6.9); however:
  Package libc-dev-bin is not configured yet.

dpkg: error processing package libc6-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dbg:amd64:
 libc6-dbg:amd64 depends on libc6 (= 2.19-0ubuntu6.9); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-dbg:amd64 (--configure):
 No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                           No apport report written because the error message indicates its a followup error from a previous failure.
                                 No apport report written because MaxReports is reached already
                                                                                               dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6:amd64
 libc-dev-bin
 libc6-dev:amd64
 libc6-dbg:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)`

If anyone has an idea …

Thanks !

Regards,

Mat


#2

@Mat_ This is not an EasyEngine issue. As stated in the error log, it rather seems to be a dpkg error caused by some I/O failure. You should do a hard disk check and look for probable cause of HDD failure. if everything comes clean, you can try to re-run sudo dpkg --configure libc6:amd64 and then sudo apt-get -f.

That should fix the issue. Thank you.


#3

Hi @ssalil ! Thanks a lot. I tried many commands, but didn’t knew the one you gave. That worked like a charm.

:thumbsup:


#4

@Mat_ Glad that I was able to help. :slight_smile:


#5

I got some error, help me please.

sudo apt-get install p7zip-full [sudo] password for phu: Reading package lists… Done Building dependency tree
Reading state information… Done p7zip-full is already the newest version (9.20.1~dfsg.1-4.2). p7zip-full set to manually installed. The following packages were automatically installed and are no longer required: canonical-poke linux-headers-4.4.0-23 linux-headers-4.4.0-23-generic linux-image-4.4.0-23-generic linux-image-extra-4.4.0-23-generic linux-signed-image-4.4.0-23-generic linux-tools-4.4.0-23 linux-tools-4.4.0-23-generic Use ‘sudo apt autoremove’ to remove them. 0 upgraded, 0 newly installed, 0 to remove and 75 not upgraded. 1 not fully installed or removed. Need to get 0 B/175 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] y dpkg: error processing package libqt5dbus5:amd64 (–configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: libqt5dbus5:amd64 E: Sub-process /usr/bin/dpkg returned an error code (1)

Then i do

sudo apt-get install --reinstall ubuntu-desktop Reading package lists… Done Building dependency tree
Reading state information… Done The following packages were automatically installed and are no longer required: canonical-poke linux-headers-4.4.0-23 linux-headers-4.4.0-23-generic linux-image-4.4.0-23-generic linux-image-extra-4.4.0-23-generic linux-signed-image-4.4.0-23-generic linux-tools-4.4.0-23 linux-tools-4.4.0-23-generic Use ‘sudo apt autoremove’ to remove them. Recommended packages: cheese firefox xul-ext-ubufox The following packages will be upgraded: ubuntu-desktop 1 upgraded, 0 newly installed, 0 to remove and 74 not upgraded. 1 not fully installed or removed. Need to get 0 B/179 kB of archives. After this operation, 0 B of additional disk space will be used. (Reading database … 253768 files and directories currently installed.) Preparing to unpack …/ubuntu-desktop_1.361.1_amd64.deb … Unpacking ubuntu-desktop (1.361.1) over (1.361) … dpkg: error processing package libqt5dbus5:amd64 (–configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Setting up ubuntu-desktop (1.361.1) … Errors were encountered while processing: libqt5dbus5:amd64 E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg --configure libc6:amd64 dpkg: error processing package libc6:amd64 (–configure): package libc6:amd64 is already installed and configured Errors were encountered while processing: libc6:amd64

sudo apt-get -f E: Command line option ‘f’ [from -f] is not understood in combination with the other options.

:confounded: someone help me please!!


#6