Double scroll bar fix causing scroll issues in Chrome on mobile


#1

Hi,

There are two issues here really. Issue 1: when clicking off the lightbox a double scroll bar appears that wasn’t there prior to opening the lightbox. The fix I found for this was to set the overflow-y to hidden on the html element. This worked, however I have noticed that this fix causes a new issue. Issue 2: page does not scroll in Chrome browser on a mobile, possibly just Android as I haven’t tested it on any other device.

I am using BeTheme with the (I believe) nicescroll scroll bar.

Any ideas on how to fix these two issues?

Thanks :slight_smile:


#2

Hello @Simon_Matthews,

Could you please confirm if you are facing this issue once you switch the theme to any other default theme of WordPress [ 2014/2015/2016 etc. ]?

This will define if there is any conflict with the theme.

Thank you.


#3

Hello @pranalipatel,

I do believe the double scroll bar is partially a theme issue. BeTheme uses a customized scroll bar by default, which is called nicescroll. As a fix I have disabled the nicescroll scroll bar and am using the normal scroll bar instead. It makes the page look less pretty but it is better than having a double scroll bar I suppose, and much better than having a page that doesn’t scroll in Chrome on a mobile.

The scroll issue is probably a Chrome issue as it only happens in Chrome for mobile.

Thanks!


#4

Hello @Simon_Matthews,

We suggest to once contact your theme developer for this issue. We hope they can help you.

Thank you.


#5

OK, thank you.


#6

You are welcome @Simon_Matthews,

I am closing this thread for now. Feel free to create new if you need any assistance.

Thank you!


#7