Domain mapping issues


#1

Hi there folks.

I installed Easy Engine using the “ee site create example.com --wpsubdom --wpfc” command and it seems that full domains (using the domain mapping plugin from WPMU) are working fine, but subdomains are not. I just added a wildcard record with Linode, so possible its a propagation thing. Wanted to see if there were any other steps I should have taken or can do to debug?

Thanks!


#2

@peter1
Please provide us little more details:

Domain Mapping Settings:

Also I’m assume you are created example.com wordpress multisite with subdomain and now you are face some issue to map external.com domain ?

Am i right?


#3

Hello Harshad,

Actually, external domains are fine. It’s the functioning of subdomains which isn’t working which made me think that something went wrong with the easy engine installation or there is something specific to my server (hosted by Linode) that’s the problem. How to test?


#4

@peter

I assume example.com and its subdomain sub.example.com is hosted on 1.1.1.1 ip address.
You can cross check the sub-domain sub.example.com is working or not using local DNS

Add following lines in your /etc/hosts file

  
vim /etc/hosts  
1.1.1.1 example.com sub.example.com  

Now visit sub.example.com in your favourite web-browser

If its working that means your *.example.com wildcard DNS is not updated.


#5

Thanks Harshad,

I added to my hosts file:

50.116.48.102 cre8tives.org peter.cre8tives.org

Tested it and the subdomain is still not showing up. So does that mean its not a wildcard DNS issue?

Many thanks for your help.


#6

@peter1

I checked your site peter.cre8tives.org on local and proxy sever and its working fine
see the attached screenshot below

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/68645/2014/07/cre8tives-news.png


#7

Ah, yes, indeed… I was also checking from a few proxies, but I guess the wrong ones, hahaha…


#8

@peter1
Hope your problem resolved. Let us know if any other issues.


#9

Well… now that you mention it… I AM having trouble figuring out how to change an apache rewrite rule. Using a custom wp-signup page and have read dozens of tutorials trying to figure out how to recode this for nginx:

RewriteRule ^wp-signup.php(.*)$ wp-content/themes/reverie-master/wp-signup.php$1


#10

@peter1
This might help you http://winginx.com/en/htaccess


#11

WOW! Exactly what I need!

Only issue is… where does the code go? I tried putting it in nginx.conf and my sites-available file but neither worked. Or do I have to run a command line after I’ve added it?


#12

@peter1

EasyEngine provides facility to edit your sites virtual config, check this


#13

Unfortunately, there’s some bug with that, as I posted in this thread:

However, I can get access to that file via SFTP. The WINGINX site gave me this:

# nginx configuration location /wp { rewrite ^/wp-signup.php(.*)$ /wp-content/themes/reverie-master/wp-signup.php$1; }

I assume that I should change /wp to the path where my wordpress files are:

location /var/www/cre8tives.org/htdocs/

I tried putting that code both within and outside of the server { } block, but neither worked.


#14

FYI, found a tutorial that said this code should go in the server{} block. Have tried virtually every configuration I can think of:

location /var/www/cre8tives.org/htdocs {
location /var/www/cre8tives.org/htdocs/ {
location / {
location /wp {
location {

And nothing works. :frowning:


#15

I’m assume you want to redirect wp-signup.php to /wp-content/themes/reverie-master/wp-signup.php

  
location = wp-signup.php {  
   return 301 $scheme://$host/wp-content/themes/reverie-master/wp-signup.php;  
}  

#16

Indeed. Just placed that in my sites-available config file within the server {} block and it didn’t work.


#17

@peter1
This worked fine for me, tested using curl
edit vim /etc/nginx/sites-available/cre8tives.org
paste this code

  
location = /wp-signup.php {  
                return 301 $scheme://$host/wp-content/themes/reverie-master/wp-signup.php;  
        }  

then do this service nginx reload


#18

Got this error message after

Reloading nginx configuration: nginx: [emerg] "location" directive is not allowed here in /etc/nginx/nginx.conf:108  
nginx: configuration file /etc/nginx/nginx.conf test failed

Tried placing the code you gave me both within and outside of server {} since you didn’t specify.

Really appreciate your help and know that we’ll get to the solution soon!


#19

Solved it! Hadn’t realized that I had left a different block of code within the conf file when I was testing things out earlier. All good now. Thanks RTCAMP! DEFINITELY going to hire you when my site gets too big for me to manage!


#20

@peter1
glad to know your problem solved