Domain Mapping Error - Just shows 'Welcome to Nginx' page


#1

Hi,

I have some problem with domain mapping.

I want to change domain aaa.mysite.com to abcabc.com. Registering the new domain name on dashboard was succeed, but the new domain just shows ‘Welcome to Nginx’ page. And on dashboard, its health status shows ‘Invalid’ status.

I setup the server with EasyEngine and using Domain Mapping plugin from WPMU dev.

Also, I tried to change the config file named ‘nginx.conf’ following steps from page :

but it did not work. Actually, there is no ‘server {…}’ code in my config file originally.

So, I cannot find my way out.

Any suggestions or comments are very welcomed. Thanks!


#2

@dhatuna

Make sure your DNS abcabc.com updated,

also could you provide us nginx configuration for your site.

Check after clearing cache, if you are using any cache mechanism.


#3

Thanks for quick reply.

I’m pretty sure that DNS is updated. I’m using DNS from digitalocean.com, and I checked the settings on the webpage.

And here’s the nginx.conf

user www-data;
worker_processes auto;
worker_rlimit_nofile 100000;
pid /run/nginx.pid;

events {
	worker_connections 4096;
	multi_accept on;
}

http {
	##
	# EasyEngine Settings
	##

	server_tokens off;
	reset_timedout_connection on;
	add_header X-Powered-By "EasyEngine 2.2.1";
	add_header rt-Fastcgi-Cache $upstream_cache_status;

	# Limit Request
	limit_req_status 403;
	limit_req_zone $binary_remote_addr zone=one:10m rate=1r/s;

	# Proxy Settings
	# set_real_ip_from	proxy-server-ip;
	# real_ip_header	X-Forwarded-For;

	fastcgi_read_timeout 300;
	client_max_body_size 100m;

	# SSL Settings
	ssl_session_cache shared:SSL:20m;
	ssl_session_timeout 10m;
	ssl_prefer_server_ciphers on;
	ssl_ciphers HIGH:!aNULL:!MD5:!kEDH;



	##
	# Basic Settings
	##

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;
	keepalive_timeout 30;
	types_hash_max_size 2048;
	# server_tokens off;

	# server_names_hash_bucket_size 64;
	# server_name_in_redirect off;

	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	##
	# Logging Settings
	##

	access_log /var/log/nginx/access.log;
	error_log /var/log/nginx/error.log;

	log_format rt_cache '$remote_addr $upstream_response_time $upstream_cache_status [$time_local] '
		'$http_host "$request" $status $body_bytes_sent '
		'"$http_referer" "$http_user_agent"';

	##
	# Gzip Settings
	##

	gzip on;
	gzip_disable "msie6";

	gzip_vary on;
	gzip_proxied any;
	gzip_comp_level 6;
	gzip_buffers 16 8k;
	gzip_http_version 1.1;
	gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

	##
	# Virtual Host Configs
	##

	include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/sites-enabled/*;
}

#mail {
#	# See sample authentication script at:
#	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#	# auth_http localhost/auth.php;
#	# pop3_capabilities "TOP" "USER";
#	# imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#	server {
#		listen     localhost:110;
#		protocol   pop3;
#		proxy      on;
#	}
# 
#	server {
#		listen     localhost:143;
#		protocol   imap;
#		proxy      on;
#	}
#}

Thanks for your help.

Best regards.

Kyu


#4