Does EE include a default 301 redirect? Infinite loop problem


#1

Running EE (3.4.1) WP --pagespeed install

When I perform curl -I www.SITE.com I get a 301 redirect to the non-www version of SITE.com

Yet, nowhere in my nginx server block do I have a 301 redirect specified for non-www. (Editing using command sudo ee site edit SITE.com)

I’ve discovered this error because I wanted to add www to the domain, but when I added the redirect below, it obviously resulted in an infinite redirect loop.

server { listen 80; server_name SITE.com; return 301 $scheme://www.SITE.com$request_uri; }

Does EE have a default redirect baked in? How do I get rid of it? I’m looking at the shared configurations and can’t find any redirect. Where is this non-www 301 I can’t find?

Thanks in advance!


#3

Try this:

Wordpress Admin > Settings > General > add www for WordPress Address (URL) and Site Address (URL)


#4