Discovering "ee stack <COMMAND>" Really Doesn't Function


#1

Hi,

I am not sure (yet) if this is a bug: I have been doing numerous tweaks and running:

ee stack restart --nginx

and after a restart I receive the

Start : nginx [OK]

A few times I ran:

ee stack restart

and ee returnes:

Restart : nginx [OK] Restart : php5-fpm [OK] Restart : mysql [OK] Restart : postfix [OK]

What is interesting that I run SQL of of Google Cloud SQL so I had removed mySQL with:

ee stack remove --mysql

Terminal had shown that it was successfully removed. When I saw that ee was showing mysql was restarting, I ran:

service --status-all

The machine returned that mysql was not installed but why does ee still shows that it is and that it restarted - I also drilled thru the sever directories after running a purge and found nothing - just the client used to connect to Cloud SQL??

Now for the REAL problem:

I am running ee on Compute Engine, n1-highcpu-4 (4 vCPU, 3.6 GB memory, Ubuntu 14.04.2 LTS (GNU/Linux 3.16.0-31-generic x86_64) for development be for the BIG release of this project.

Thru-out the day, I stop the instance when I am not working on the project (Google doesn’t charge when the instance is off :wink: and I boot it up when I need it. During after hours (over-night), I shut down the instance and reboot in the morning but I find the ee server is not responding…? This has happened for the third day in a row now. What I discovered is if I run:

ee stack restart --nginx or ee stack start --nginx or ee stack stop and ee stack start

I get a return from ee that everything is O.K. I try to access the site and still no response from the server. Back in terminal I run:

service --status-all

and that returns NGINX is not running! So what is REALLY going on here? I have tried every way imaginable to start NGINX the traditional way or the ee way and it doesn’t start even-though ee says it is…

The only way around this is for me to start a new instance with a snapshot. I am starting to find that ee may not be reliable because I was experiencing the same thing a few months ago on a Digital Ocean image but I blew it off as a flewk.

Please, any help here would be greatly appreciated and I don’t wan’t to give up on ee just yet - It does make set up much easier.

Thnx,

jason

PS: I also can’t access the logs using ‘ee log’ because ee isn’t really running in this situation - it just locks up terminal -weird.

UPDATE:

This seams to be an ee cache issue(?) At the end of the day I work on some security settings for the server. When I close and save the config files, I see the “Restart : nginx [OK]” and assume all is well. Then I shut down the instance and the next morning, all is not well.

Today I discovered when I opened back up a config, added a space between a line, closed and saved, I got a Reload : nginx [Failed]. I manually looked into the logs and discovered I had a typo from an edit the day before. This tells me that when a edit is done on a config, ee is checking against the cache and is returning what it sees there. Maybe rtCamp can modify the script to purge the cache when a config file is saved??

Like I had said, I was ASSUMING because ee was outputting "Reload : nginx [OK]’ after a save - This is misleading that it is purging everything with a restart. Even after running “ee stack restart” a all is OK was returned because its checking the cache not the changes - I don’t get any errors from ee until the instance has been turned off. Even when I run “ee stack restart” in the morning. I only see errors after editing a config - I am I right on this?? Thnx -j


#2

Hi @jasonalankenned ,

We are looking into this issue. we will get you soon after checking…


#3

Thnk for checking into the issue.

To reinforce what I am seeing:

I turned on SPDY today with:

listen 443 deferred ssl spdy

I exit nano, saved then ran:

ee stack restart and ee stack restart --nginx

I purged NGINX, cleared my browser cache (Running in Incognito) reloaded the page.

I next tested SPDY with http://spdycheck.org/ and it returned that SDY wasn’t on :stuck_out_tongue:

I next ran all the steps again and spdycheck still said that SPDY is not running. I waited and hour and went thru all the steps again and still a no-go.

Then I shut down the server instance, waited 10 minutes, rebooted and ran the spdycheck and it is now working.

So again, it’s looking like the “ee stack COMMANDS” really don’t do anything. I hope I am not sounding rude and I apologize if I do but I have no issues of this if I run my own NGINX compiles and run the good-old-fashioned restart commands. I like the simple commands but…

What is you thoughts?

Thnx again for your help,

-j


#4

I just checked http://spdycheck.org/#rtcamp.com and its SPDY is working correctly.

I am not sure what do you mean by ee stack commands.

SPDY is something you need to manually enable by editing nginx config file at the time of SSL setup. Currently EE doesn’t support creation of SSL site.


#5

By the way if you wish to clean cache, you may use ee clean command - http://docs.rtcamp.com/easyengine/commands/clean/


#6

Hi @jasonalankenned

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#7