Disallowing Audio and Video Uploads Doesn't Work


#1

Hello,

Since I don’t want members to upload music or video as that would cause storage issues on my servers, I assumed by disallowing video and audio on the rtmedia settings page that it wouldn’t allow anyone to upload mp3’s or mp4’s. Instead it only gets rid of the audio and video tabs on the media page of the profile, but still allows people to upload audio and video…

Any help on this would be excellent and much appreciated as I will have to look elsewhere if this is truly the case.

Thank you,
Nicholaus


#2

We will fix that soon. Thanks for pointing this.


#3

Any update on this?? It’s still doing what nicholaus above has described


#4

Hi @mmaccou,

This option is available for admin to Allow or Disallow uploads of videos and music. Documentation -> http://docs.rtcamp.com/rtmedia/getting-started/settings/#Types.

Which version are you using ?


#5

I know the option is available, but the user can still select an audio or video file from their computer and hit upload with no error message. The result is the caption of the post showing and no audio/video. It’s not a good user experience because they wont know that they arent able to upload those files and will think my site is broken. I’m using version 3.7.16


#6

Hi @mmaccou,

If ‘Allow Upload’ is disabled from the rtMedia admin settings and user tries to upload that type a error message occurs with text ‘File not supported’. If user still tries to upload that post then post will be posted without media and only with post-caption.

Are you getting any JavaScript error ? Can you please once try it with WordPress default theme and other plugins disabled?

We have tested again on our end and it is working good.


#7