Debian 8 and EasyEngine


#1

Does EasyEngine support the newly released Debian 8 or Ubuntu 15.04?


#2

@rdlynch

For debian we are using dotdeb repository to provide latest nginx php and mysql packages And as of now dotdeb doesn’t update its php and mysql/mariadb package for debian 8 :frowning:


#3

I just checked and Dotdeb now supports Debian 8.x “Jessie“: https://www.dotdeb.org/about/

Any update on EasyEngine support for Debian 8?


#4

I guess I figured out the answer to my own question. Looks like EE is not using dotdeb anymore. https://rtcamp.com/blog/easyengine-3-2-opensuse-build-service/

From the new OpenSuse package build status page, Debian 8 should be fully supported: https://build.opensuse.org/project/monitor/home:rtCamp:EasyEngine

I went ahead and tried it. On first server, I did dist-upgrade from Debian 7 to 8. All EE features worked without a hitch.

Then I wanted to start afresh, so I grabbed a minimal Debian 8 OpenVZ template from OpenVZ.org. Unfortunately this didn’t work: when I enter the EE install command (wget -qO ee rt.cx/ee && sudo bash ee) the prompt returns immediately, with no on-screen feedback. I’m thinking some required packages are not available in the minimal OpenVZ template I used.


#5

Hi @rdlynch

EasyEngine very well supports Debian 8 although it doesn’t currently supports Ubuntu 15.04.Refer here.

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#6