Creating subdomain: Couldn't connect to global-db:3306


#1

Hi,

Using the command:

sudo ee site create examplesite --wp --cache --le-mail=email --letsencrypt

And get the following output:

Error: Unable to download wp core.

Warning: Couldn’t connect to global-db:3306 or there was issue in wp config create. Please check logs.

Warning: Initiating clean-up.

Can anybody help? Do you need something more? (I managed to create a html subdomain but the problems still occur when trying to download WP.)


#2

you run command
docker ps
and see if mysql’s docker is available. If yes, check its network.

docker inspect <containerNameOrId>


#3

I have the exact same problem:

Spun up a new Ubuntu 18 LTS server.
Installed newest EE.
Created WP site with caching, le php7.3 and a domain like dev.example.com
Now I wanted to make the site example.com and it gave me the same error above mentioned.

docker ps showed all the containers running
docker inspect of the mysql container seemed normal although I am not experienced reading that output

I guess this is a bug that should be escalated to a GitHub issue.


#4

Sorry, my mistake, I used an online non-interactive shell, with my normal shell client it worked.