Creating site via ee results in MYSQL db connectivity error


#1

Hi all!

Was trying to setup a test site under a subdomain. But the attempt result in “oops Something went wrong!”

This is the ee log output:

2015-09-26 17:39:26,074 (INFO) ee : e[94mSetting up NGINX configuration 	e[0m
2015-09-26 17:39:26,075 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2015-09-26 17:39:26,204 (DEBUG) ee : e[95mChecking generated nginx conf, please wait...e[0m
2015-09-26 17:39:26,357 (INFO) ee : e[94m[e[0mDonee[94m]e[0m
2015-09-26 17:39:26,358 (DEBUG) ee : e[95mCreating Symbolic link, Source:/etc/nginx/sites-available/seotest.saskialund.de, Dest:/etc/nginx/sites-enabled/seotest.saskialund.dee[0m
2015-09-26 17:39:26,358 (INFO) ee : e[94mSetting up webroot 		e[0m
2015-09-26 17:39:26,359 (DEBUG) ee : e[95mCreating Symbolic link, Source:/var/log/nginx/seotest.saskialund.de.access.log, Dest:/var/www/seotest.saskialund.de/logs/access.loge[0m
2015-09-26 17:39:26,359 (DEBUG) ee : e[95mCreating Symbolic link, Source:/var/log/nginx/seotest.saskialund.de.error.log, Dest:/var/www/seotest.saskialund.de/logs/error.loge[0m
2015-09-26 17:39:26,360 (INFO) ee : e[94m[e[0mDonee[94m]e[0m
2015-09-26 17:39:26,556 (INFO) ee : e[94mDownloading Wordpress 		e[0m
2015-09-26 17:39:26,556 (DEBUG) ee : e[95mChanging directory to /var/www/seotest.saskialund.de/htdocs/e[0m
2015-09-26 17:39:26,556 (DEBUG) ee : e[95mRunning command: wp --allow-root core downloade[0m
2015-09-26 17:39:27,952 (INFO) ee : e[94m[e[0mDonee[94m]e[0m
2015-09-26 17:39:42,450 (INFO) ee : e[94mSetting up database		e[0m
2015-09-26 17:39:42,452 (DEBUG) ee : e[95mCreating database seotest_sle[0m
2015-09-26 17:39:42,462 (DEBUG) ee : e[95me[0m
2015-09-26 17:39:42,462 (DEBUG) ee : e[95m'MySQL Connectivity problem occured'e[0m
2015-09-26 17:39:42,463 (INFO) ee : e[94me[91mOops Something went wrong !!e[0m
2015-09-26 17:39:42,463 (INFO) ee : e[94me[91mCalling cleanup actions ...e[0m
2015-09-26 17:39:42,463 (DEBUG) ee : e[95mRemoving Nginx configuratione[0m
2015-09-26 17:39:42,463 (DEBUG) ee : e[95mRemoving /etc/nginx/sites-enabled/seotest.saskialund.dee[0m
2015-09-26 17:39:42,464 (DEBUG) ee : e[95mRemoving /etc/nginx/sites-available/seotest.saskialund.dee[0m
2015-09-26 17:39:42,464 (INFO) ee : e[94mReload : nginx     e[0m
2015-09-26 17:39:42,924 (INFO) ee : e[94m[e[0mOKe[94m]e[0m
2015-09-26 17:39:42,949 (DEBUG) ee : e[95mRemoving /var/www/seotest.saskialund.dee[0m
2015-09-26 17:39:42,949 (DEBUG) ee : e[95mRemoving /var/www/seotest.saskialund.dee[0m
2015-09-26 17:39:43,026 (ERROR) ee : e[91mCheck logs for reason `tail /var/log/ee/ee.log` & Try Again!!!e[0m

MySQL connectivity issue? Why would that happen? mysql is running fine. And I can log into mysql as root and all…

Any ideas?


#2

Hello @SaskiaLund

Could you please tell which EE version you are using ?

Could you also please check mysql credentials at /etc/mysql/conf.d/my.cnf are correct and try to login to mysql using the credential with command :

mysql -u user -p


#3

Hi @Prabuddha !

Thanks for your reply!

I am using

EasyEngine v3.3.8
Copyright © 2015 rtCamp Solutions Pvt. Ltd.

root@server:~# nano /etc/mysql/conf.d/my.cnf
root@server:~# mysql -u root -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 4485
Server version: 10.0.21-MariaDB-1~trusty-log mariadb.org binary distribution

Copyright © 2000, 2015, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> show databases
-> ;
±-------------------+
| Database |
±-------------------+
| information_schema |
| mysql |
| performance_schema |
| roundcubemail |
| saskialund_de |
| slow_query_log |
| vimbadmin |
±-------------------+
7 rows in set (0.01 sec)

MariaDB [(none)]>

This is what I was testing in the first place, when I read about MySql connectivity in ee.log

Do you have an idea why this error would be happening?


#4

Hello @SaskiaLund

Could you please tell whether you are using Remote Mysql server ?

Could you able to login to mysql through only command :

mysql


#5

Hi @Prabuddha !

I haven’t set up the remote MySql… it’s just as it was when ee installed it all. Yes, I can login using only mysql command:

root@server:~# mysql
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 4576
Server version: 10.0.21-MariaDB-1~trusty-log mariadb.org binary distribution

Copyright © 2000, 2015, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> show databases
-> ;
±-------------------+
| Database |
±-------------------+
| information_schema |
| mysql |
| performance_schema |
| roundcubemail |
| saskialund_de |
| slow_query_log |
| vimbadmin |
±-------------------+
7 rows in set (0.00 sec)

MariaDB [(none)]>

Thanks once more


#6

Hi @Prabuddha !

Do you have any idea why site creation is not working in this case?


Site create fails 'ee_mysql_grant_host', despite seemingly valid config
#7

@Prabuddha has fixed it! Reason was: easy engine’s python library, that is being used for mysql connectivity does not support any local languages. Issue was with /etc/mysql/my.cnf file lc_messages parameter .

By reverting back to:

lc_messages = en_US

the problem was solved.

Thank you Prabuddha!!


#8

@SaskiaLund

As the issue is solved, i am closing this thread. Feel free to create new ticket if you have any doubt.


#9