Creating new repo SQL error


#1

When I click 'Add Gitolite Repository' from the Admin->Tools->Source page and enter in new info for a repository it fails with the message that the disable_notifications field can not be NULL. My fix for this was to edit the table structure to allow NULL, but you probably want to fix this in your source.


#2

@petrocket

SQL error looks strange! May be module is not activated properly during installation process.

Just try going to activeCollab modules section (your-activecollab.com/admin/modules URL) and click on uninstall button and then install button.

If you face error after that as well, just let us know. We will check it further.


#3

It looks like a possible reason for this error is the ac_gitolite/views/default/ac_gitolite_source/add_source_gitolite_repository.tpl is missing the code for the repository[disable_notifications] field which is set to not allow NULL values, so when the code on line 254 of AcGitoliteSourceController.class.php is run it passes $repository_data which is missing the disabled_notifications fields so when the variables are inserted into the MySQL INSERT statement the last one (disable_notifications) is missing.

Simple fix would be to add it in code or add a field in the form like you have in ac_gitolite/views/default/project_tracking_gitolite/add_git_repo.tpl

{wrap field=name} {label for=repositoryNotification required=false}{lang}Disable Notifications{/lang}{/label}

                {lang}Disable notifications every time commits are made on this repository.{/lang}  
             {/wrap}   

#4

@petrocket

Sorry for inconvenience.

I just noticed that some codes are slipped into stable build for notification-management and also FTP-based upload functionality (planned in version 1.5)

This will be rectified in next release due this Thursday.

I apologize again for inconvenience. I hope your gitolite module is in working state as of now.


#5