Create wordpress site fails on a server with existing MySQL database


#1

I have a server with existing MySQL wordpress database. I installed all packages individually except MySQL. Below is the ee status and info.

I can also connect to database as root using “mysql” command. However, when I try creating a wordpress site it fails at the point where it has to create a database.

Can’t easyengine be used to create wordpress sites on servers with existing databases? Log below. Thank you.

testdb@test-sql:~$ sudo ee stack status
nginx     :  Running
php5-fpm  :  Running
mysql     :  Running
postfix   :  Running
hhvm      :  Running
testdb@test-sql:~$
testdb@test-sql:~$ sudo ee info

NGINX (1.8.0):

user                             www-data
worker_processes                 auto
worker_connections               4096
keepalive_timeout                30
fastcgi_read_timeout             300
client_max_body_size             100m
allow                            127.0.0.1

PHP (5.6.14-1):

user
expose_php                       Off
memory_limit                     128M
post_max_size                    100M
upload_max_filesize              100M
max_execution_time               300

Information about www.conf
ping.path                        /ping
pm.status_path                   /status
process_manager                  ondemand
pm.max_requests                  500
pm.max_children                  100
pm.start_servers                 20
pm.min_spare_servers             10
pm.max_spare_servers             30
request_terminate_timeout        300
xdebug.profiler_enable_trigger   off
listen                           127.0.0.1:9000

Information about debug.conf
ping.path                        /ping
pm.status_path                   /status
process_manager                  ondemand
pm.max_requests                  500
pm.max_children                  100
pm.start_servers                 20
pm.min_spare_servers             10
pm.max_spare_servers             30
request_terminate_timeout        300
xdebug.profiler_enable_trigger   on
listen                           127.0.0.1:9001

MySQL (5.5.44) on localhost:

port                             3306
wait_timeout                     28800
interactive_timeout              28800
max_used_connections             5
datadir                          /var/lib/mysql/
socket                           /var/run/mysqld/mysqld.sock
testdb@test-sql:~$ mysql
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 457
Server version: 5.5.44-0ubuntu0.14.04.1 (Ubuntu)

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show grants;
+----------------------------------------------------------------------------------------------------------------------------------------+
| Grants for root@localhost                                                                                                              |
+----------------------------------------------------------------------------------------------------------------------------------------+
| GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' IDENTIFIED BY PASSWORD '*MASKEDTHEPASSWORD' WITH GRANT OPTION |
| GRANT PROXY ON ''@'' TO 'root'@'localhost' WITH GRANT OPTION                                                                           |
+----------------------------------------------------------------------------------------------------------------------------------------+
2 rows in set (0.00 sec)

mysql> exit
Bye
testdb@test-sql:~$ sudo ee site create example.com --wpsubdir --wpredis
Redis is experimental feature and it may not work with all CSS/JS/Cache of your site.
You can disable it by changing cache later.
Do you wish to enable Redis now for example.com?
Type "y" to continue [n]:y
Running pre-update checks, please wait...
Setting up NGINX configuration     [Done]
Setting up webroot         [Done]
Downloading Wordpress         [Done]
Setting up database        Oops Something went wrong !!
Calling cleanup actions ...
Reload : nginx     [OK]
Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!!
testdb@test-sql:~$ sudo tail -15 /var/log/ee/ee.log
2015-10-07 19:42:28,862 (INFO) ee : [Done]
2015-10-07 19:42:28,864 (INFO) ee : Setting up database
2015-10-07 19:42:28,864 (DEBUG) ee : Creating database example_com
2015-10-07 19:42:28,870 (DEBUG) ee :
2015-10-07 19:42:28,870 (DEBUG) ee : 'MySQL Connectivity problem occured'
2015-10-07 19:42:28,871 (INFO) ee : Oops Something went wrong !!
2015-10-07 19:42:28,872 (INFO) ee : Calling cleanup actions ...
2015-10-07 19:42:28,872 (DEBUG) ee : Removing Nginx configuration
2015-10-07 19:42:28,872 (DEBUG) ee : Removing /etc/nginx/sites-enabled/example.com
2015-10-07 19:42:28,873 (DEBUG) ee : Removing /etc/nginx/sites-available/example.com
2015-10-07 19:42:28,873 (INFO) ee : Reload : nginx
2015-10-07 19:42:29,083 (INFO) ee : [OK]
2015-10-07 19:42:29,357 (DEBUG) ee : Removing /var/www/example.com
2015-10-07 19:42:29,358 (DEBUG) ee : Removing /var/www/example.com
2015-10-07 19:42:29,513 (ERROR) ee : Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!!
testdb@test-sql:~$

#2