Connection to MySQL


#1

Hi,

Don’t understand why I can’t access to phpmyadmin…

I have tried to access it on https://example.com:22222/db/pma/

Which pass and login I have to use?

I have tried root login with the specific pass find with the command cat ~/.my.cnf and log/pass found with “ee site info example.com

Furthermore I have tried both and i got the same result I stay on the same screen, the only thing happens is I’ve got a token in the url after I had click the “go” button.

I have http authentication who works well, however I’m not comfortable with Unix language I had my ip addresses in the withelist (/etc/nginx/common/acl.conf)

Would you please help me ?


#2

EasyEngine Admin Tools (22222 port) are protected by HTTP Authentication

Refer: https://github.com/rtCamp/easyengine/wiki/Admin-Tools

Once you provide the right combination for HTTP Authentication then you can see the phpMyAdmin login screen where you have to enter MySQL login details.


#3

I already access to the mysql identification page with the http authentification.

Screen i got > http://hpics.li/f5fd062.

But I can’t acces to the admin with the pass and login I have.


#4

@antoine_biswang I had tested on fresh Ubuntu 14.04 64 bit and its working fine

Can you found any error messages at /var/www/22222/logs ?

Also refer this: https://github.com/rtCamp/easyengine/issues/302


#5

Yeah !!!

Solved with the two command lines :

chmod a+t+w /var/lib/php5
chmod go-r /var/lib/php5

The problem was the PHP session directory.

Thx for your help and reactivity


#6

Hello @antoine_biswang

Glad to know your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#7