Connection timed out after Let's Encrypt certificate installation


#1

Hi,

I just installed Let’s Encrypt for my one of my pages and now I cannot access the page, I get ERR_CONNECTION_TIMED_OUT. I tried both off to get back to http version of the site.

Can someone please take a look what is wrong? :frowning:

What log file do I need to check? Thanks for every help :slight_smile:

alma@alma:/var/www# ee site update kremelina.cz --letsencrypt
Letsencrypt is currently in beta phase.
Do you wish to enable SSl now for kremelina.cz?
Type "y" to continue [n]:y
Downloading LetsEncrypt          [Done]
Please Wait while we fetch SSL Certificate for your site.
It may take time depending upon network.
Let's Encrypt successfully setup for your site
Your certificate and chain have been saved at /etc/letsencrypt/live/kremelina.cz/fullchain.pem
Configuring Nginx SSL configuration
Adding /var/www/kremelina.cz/conf/nginx/ssl.conf
Adding /etc/nginx/conf.d/force-ssl-kremelina.cz.conf
Added HTTPS Force Redirection for Site  http://kremelina.cz
Creating Cron Job for cert auto-renewal
Reload : nginx     [OK]
Congratulations! Successfully Configured SSl for Site  https://kremelina.cz
Your cert will expire within 89 days.

#2

Rookie mistake. My 443 port was blocked by FW rule.

Adding solved the issue :slight_smile: sudo ufw allow 443/tcp


#3