Connection Refused after upating to letsencrypt


#1

Hello I’ve done a number of site updates to Http2/Letsncrypt yet today on a new server I’ve managed to lock it up completely. I followed the instructions on the blog post and now I’m getting This webpage is not available

ERR_CONNECTION_REFUSED


#2

I’ve also tried rolling back to stable nginx and removing letsencrypt yet its’ still forcing https


#3

Check the following directory:

/etc/nginx/conf.d/

if you see the following kind of files:
force-ssl-yourdomain.com.conf

delete those.

restart nginx as root like so:

service nginx restart

Make sure to delete browser cache and cookies as well as server cache before browsing to your site again.


#4

I’ve got it working again but I’d like to try re-enabling letsencrypt, any ideas what may have been the original cause?


#5

If you’d post the output of this command there is a chance to assist you remote wise:

ee site show yourdomain.com

as well as some more info about the current config… you might want to post the output of above command in current state before upgrading to mainline and letsencrypt. Please also provide useful info that might be showing in error.log under /var/log/nginx/

Just provide some more info…


#6

Sure I’m running on a digital ocean Ubutu box, below is the ee site show Display NGINX configuration for mysite.nyc

server {

server_name webwork.nyc   www.mysite.nyc;



access_log /var/log/nginx/mysite.nyc.access.log rt_cache;
error_log /var/log/nginx/mysite.nyc.error.log;
root /var/www/mysite.nyc/htdocs;



index index.php index.html index.htm;


include common/php.conf;

include common/wpcommon.conf;
include common/locations.conf;

} Error log show below 2016/01/24 14:33:44 [warn] 10610#10610: conflicting server name “mysite.nyc” on 0.0.0.0:80, ignored 2016/01/24 14:33:44 [warn] 10610#10610: conflicting server name “www.mysite.nyc” on 0.0.0.0:80, ignored


#7

Anyone else have any ideas on this?


#9

Attempted to re-enabled mainline and letsencrypt with the same issues


#10

You can disregard, I moved the site back to shared hosting.


#11

Just a note for people running in a similar problem : for me the issue was coming from my firewall which was blocking 443 connection. So doing “sudo ufw allow 443” solved the problem.


#12

I gave this a shot in hopes it would work for me too but to no avail :frowning:

I’m running into this in linode. everything seems to be fine until I get the good news that lets encrypt was successful. I’ve tried this on two existing websites (running with easyengine for ages) with the same results so I’m not sure what I’m doing wrong here.

sudo ee site update charlotterocks.com --letsencrypt
 Letsencrypt is currently in beta phase.
 Do you wish to enable SSl now for charlotterocks.com?
 Type "y" to continue [n]:y
  Please Wait while we fetch SSL Certificate for your site.
  It may take time depending upon network.
  Let's Encrypt successfully setup for your site
  Your certificate and chain have been saved at /etc/letsencrypt/live/charlotterocks.com/fullchain.pem 
  Configuring Nginx SSL configuration
  Adding /var/www/charlotterocks.com/conf/nginx/ssl.conf
  Adding /etc/nginx/conf.d/force-ssl-charlotterocks.com.conf
  Added HTTPS Force Redirection for Site  http://charlotterocks.com
  Creating Cron Job for cert auto-renewal
  Reload : nginx     [OK]
  Congratulations! Successfully Configured SSl for Site  https://charlotterocks.com
  Your cert will expire within 89 days.


From then on the websites it has been added on are inaccessible.

When I went to reload nginx I see these warnings but I’m not sure where to change them. Here is the output:

sudo nginx -t && service nginx reload nginx: [warn] conflicting server name “charlotterocks.com” on 0.0.0.0:80, ignored nginx: [warn] conflicting server name “www.charlotterocks.com” on 0.0.0.0:80, ignored

opening up 443 in the firewall did not change change anything. I’ll keep digging but if anyone else has any good ideas please let me know!

even turning it off like this does nothing :frowning: sudo ee site update charlotterocks.com --letsencrypt=off

also looked at these tips as well but they did not seem to resolve it either - http://stackoverflow.com/questions/11426087/nginx-error-conflicting-server-name-ignored


#13

anyone fixed this issue I am also having this error can’t access my site after adding --letsencrypt


#14