Configuring EE Nginx to work with multiple sites. 403 error. help


#1

Hi there, today i created a new droplet with Ubuntu 14.04. Than i installed EasyEngine by typing wget -qO ee rt.cx/ee && sudo bash ee

Okay, that worked well.

Tried to access my website through droplets IP adress - http://178.62.202.230/ It works well and showed me nginx welcome page.

Than i wanted to create a simple site with php and mysql support and typed - ee site create mli.lv --mysql

That also went well ,but the problem is, i cant access it. But i want that mli.lv is the main site for my droplet. So i moved the mli.lv folder into html folder and changed the /etc/nginx/sites-available/default.conf this line - root /var/www/html; to this line root /var/www/html/mli.lv/htdocs; but now i am getting 403 forbidden error.

So basicly what i need is that accessing my droplets IP (http://178.62.202.230/ , later gonna changed it to a domain) i access my mli.lv folder, because it’s configured to have php and mysql support and use it as a multisite.

For example. I created another website with EE , but this time with pre-installed wordpress. ee site create gamingsdeal.com --wpsubdir --wpfc and it created a folder named gamingsdeal.com in /var/www/ folder , but what i want is to move that site in mli.lv folder (because that is the main folder for my website) and access it trough my droplets ip, in this case - http://178.62.202.230/gamingsdeal.com , because i’m gonna create and host for a while multiple websites.

But so far i am getting 403 forbidden errors. Can somebody help me with this, please?


#2

#3

Hi @ASasquatchLV

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile: