Compile the latest nginx release from source with EasyEngine


#43

@virtubox Hello and thank you for your bash script so much! I have compiled Nginx without any problem. But I could not turn on WebP support – rewrite rules doesn’t work.

A have converted all images to .webp, added correct mime type. I have modified Nginx config according to your instructions - https://github.com/VirtuBox/nginx-ee/blob/master/doc/webp.md

May be Redis cache cause this problem?


#44

Hello, yes, it’s maybe an issue related to redis cache. What have you used to convert your images ? And do you use Cloudflare ?


#45

I used EWWW Image Optimizer plugin to convert. All images can be accessed with their direct links, for example - https://spain-residence.com/wp-content/uploads/2016/10/kate-smiling-400.png.webp

I use Cloudflare as DNS service only, no caching is enabled there.


#46

New release of nginx-ee bash script available !

Changelog :

  • unified script
  • add menu to choose modules
  • add naxsi support

#47

Hey @virtubox Thanks a ton for your regular work for server optimization. Using the latest version of your bash script without any issue.

Just one request, if possible, please consider this patch in the next release: https://github.com/cloudflare/sslconfig/blob/hpack_1.13.1/patches/nginx_1.13.1_http2_hpack.patch


#48

Hello, I will have to take a look because there was issues with nginx 1.13.8 previously.


#49

Update : New Nginx release - v1.13.9 added in nginx-ee script


#50

Need help with webp support. I have Added the file webp.conf in /etc/nginx/conf.d folder. And a wepb-enabled.conf file in my website’s nginx configuration folder /var/www/example.tld/conf/nginx/ As defined in Virtubox’s Github Wiki.

Then, I added example.jpg and example.jpg.webp images in /wp-content/upload/ directory. But When I load my article with example.jpg in it, there is no webp image support. Am I doing anything wrong here? or Is it essential to have Nginx Pagespeed Module for .webp serving?


#51

There is a patch available for wp-includes/post-template.php to fix count () in php 7.2


#52

Hi, is this compatible with Ubuntu 14.04.5 LTS yet?


#53

No, Nginx Pagespeed isn’t required for webp support.

Hi, is this compatible with Ubuntu 14.04.5 LTS yet?

@mdotk, I haven’t tried to run the script on Ubuntu 14.04 LTS. I will have to check if all dependencies are available.


#54

I tried Ubuntu 14.04, there are unmet dependencies (what I used as a motto to force all my servers to be upgraded to 16.04).


#55

And why I have just spun up a new 16.04 server :smiley:


#56

We follow this guide for php7.2 (7.1)? https://kb.virtubox.net/knowledgebase/install-php71-php72-fpm-easyengine/

And is there any way that upgrading Nginx as in this thread could cause Lets Encrypt certificate issuance to stop working?


#58

Hello,

it should not impact Let’s Encrypt certificates issuance because I have only used the original EE configuration files. But I use acme.sh to manage my Let’s Encrypt certficates.


#59

I too wondered about that, but thanks for clarifying.


#60

Thanks, I have no idea if it means anything, but I just did 2 fresh installs.

First time I used the script above plus https://github.com/VirtuBox/ubuntu-nginx-web-server and then tried to obtain a letsencrypt cert via easyengine. Wouldn’t work. Just stayed there on “trying to get it” (can’t remember exact words) and woudn’t return an error or anything. Nothing in logs. Would sit there indefinitely.

Then did fresh install with vanilla easyengine and SSL cert works fine. Issued in 30 secs.


#61

I will take a look on this issue.

I will also publish a bash script to issue Let’s Encrypt certs just by running a single command with acme.sh. I’m already using it on my servers and it work for domain and subdomain.


#62

Hi Virtubox,

what do we do to update to new version of nginx? run the script again everytime there is an update?


#63

Yes, just run the script again