Changing the Default tab name from Media to gallery redirection issue


#1

Hi there, Sorry for the bump, but few days ago I change all the rtMedia slug by following this doc: http://rtcamp.com/rtmedia/docs/developer/rtmedia-defined-constants/ It works well (after updating wordpress permalink structure) until I tried to delete a photo, it has been well deleted but the redirection failed and did not redirect me to the album, as it does normaly. In fact, the redirection URL keeps the "media" slug instead of my own. Is this bug known or am I the only one who it happens to? Thanks for the plugin !!


#2

@capobianco.brice - We tested this on our end and it works fine. Are you using the latest version of rtMedia?


#3

Hi, thanks for your reply. Yes, is use the latest version of rtMedia, but I thinks i'm still on Wordpress 3.5 in my preprod server. I'll try to update everything to night in will give you a feed back. Last question, is it absolutely necessary to put the slugs declaration in wp-config or could it be done in function.php ? Best


#4

It is advisable to keep it in the wp-config.php file to make sure it loads before the plugin loads. You could give it a try though.


#5

Hi, I update rtmedia to the latest version (3.1.2), but I have a new bug (maybe its not). After updating, my media page were break, in fact, the DOM/graphic structure was really strange but everything seems to work well. So, I investigate, and discorver that the plugin is now using the default wordpress page template instead of the member/plugin as before (I thaught it was). Is it due to a bad update or is it because you simply change the way page are now generated ? If so, is there a way to call a specific template to avoid thie "issue" ? Like page-rtmedia.php for exemple ?

Finally @joshuaabenazer you were write for the SLUGs, it doesnt work at all for me when I put them in functions.php

Thanks in advance

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/46196/2013/09/2013-09-15_030521.png


#6

@capobianco.brice - You can override the templates. Check this link her for more info -> http://rtcamp.com/rtmedia/docs/developer/templating-system/

Except for the main.php other templates should get overriden in 3.1.2.


#7

Hi @joshuaabenazer, after updating rtmedia (to 3.12), override my custom rtmedia template files by the new ones, and a few test, I was right. The default template page "page.php" (of my wordpress template) is used as the main structure of rtmedia pages (where main.php is called). So, I had to add some conditional tags in my page.php file to resolve my problem. Cheerse


#8

@capobianco.brice - Glad to know you could get it solved :)


#9