Change the maximum open files settings in redis-server


#1

Hi,

When I start the redis-server, it will show following warning in log file

1900:M 15 Jul 11:50:27.104 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.

1900:M 15 Jul 11:50:27.104 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.

I had changed the values in /proc/sys/fs/file-max and /etc/security/limits.conf but it seems redis-server does not affect by these settings.

Is there any other settings I should change?


#2

@Enterpr1se sorry for delayed reply. I also ran into same issue today and wrote down all my tweaks here - https://easyengine.io/tutorials/redis/

You may like to jump to https://easyengine.io/tutorials/redis/#maxclients section.

Please let me know if you still face any issue.


#3

cool


#4