Change example.com to www.example.com causes too many redirect


#1

Hi guys,
Since v4 there are a lot of tools that are not available anymore (site edit for example).
I created example.com to migrate an old Apache wordpress install.
Migrated everything but the only url working was the one using no www subdomain while the official domain was the one using it. I updated wp_options and main.conf with no luck.
On v3 I just used ee site edit but here seems not to work. Also ee stack restart doesn’t work.
Do you have any hint for me?

BTW the new install uses SSL and the older didn’t.


#2

I think it would be easier to just delete your site and create it again, but this time with the www.


#3

@antocorr I got into the same problem, I did backup, delete and recreate the site using www, then restored the backup.

Waiting for ee site update


#4

Does anyone have a fix for this? On V3 I would just change the domain to www in the wordpress settings and had no issues, now when I do that I get the redirect loop error.