Can't Upload More Than 1mb When rtmedia Pro Is Activated


#1

I remember pointing this out last year for buddypress media (rtmedia) in a past thread now resolved. It was for the free version and it was later fixed by refactoring the uploader. I just upgraded to RTMedia Pro. The problem occurs when I activate RTMedia Pro. Files can’t be uploaded over 1 mb. When I deactivate RTMedia Pro, uploading starts back working fine and files can uploaded over 1mb.

Again,

  1. When rtmedia Pro is activated, files cannot be uploaded larger than 1mb.
  2. When rtmedia Pro is deactivated, the problem doesn’t exist.

Your help would be appreciated.

PHP 5.4.25
MYSQL 5.1.72
WordPress 3.8
BuddyPress 1.8.1
rtMedia 3.6.6
OS Linux
Imagick Not Installed
GD bundled (2.1.0 compatible)
[php.ini] post_max_size 100M
[php.ini] upload_max_filesize 100M
[php.ini] memory_limit 256M
Nginx


#2

Kindly cross check the settings on rtMedai pro, we have provided upload limit under Settings -> Types. I haven't faced this issue, just checked it on our demo site http://demo.rtcamp.com/rtmedia/ and its working fine for me.


#3

Found out what it was after comparing the source of the html of (rtmedia free and rtmedia pro) to to see why it was limiting the file to 1mb. In the source of the hmtl for the uploader it said max file size 2mb for both. I knew the php.ini had been set for 100mb for a long time, even in the RTmedia debug section it showed 100 mb.

So it dawned on me to check the php.ini file and for some odd reason it looked like it had been opened up in binary format and had jumbled all the lines together. Edited it, re-uploaded it in ASCII and tested it again. All is well!

What's funny is the free version worked fine despite the php.ini being jumbled, but when rtmedia pro is activated the uploading wouldn't allow anything over 1mb.

The odd things that occur.

Thanks Nitun.


#4

@Charla I think you are already discussing this issue with our developer on premium support ticket. Please provide us your site credential there, so we can cross check it.

Thanks.


#5